summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-27 13:43:50 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-10-27 13:43:50 +0200
commitbdd42fe6dd369312e9df15fd273fdb22319bbf14 (patch)
treeaff3d5cd420625efb785083f45fba6e01028ce8c /dev-python/mypy_extensions
parentdev-python/jupyterlab: enable py3.11 (diff)
downloadgentoo-bdd42fe6dd369312e9df15fd273fdb22319bbf14.tar.gz
gentoo-bdd42fe6dd369312e9df15fd273fdb22319bbf14.tar.bz2
gentoo-bdd42fe6dd369312e9df15fd273fdb22319bbf14.zip
dev-python/mypy_extensions: enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mypy_extensions')
-rw-r--r--dev-python/mypy_extensions/Manifest1
-rw-r--r--dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/mypy_extensions/Manifest b/dev-python/mypy_extensions/Manifest
index 94a678b25e73..a2d859a380f0 100644
--- a/dev-python/mypy_extensions/Manifest
+++ b/dev-python/mypy_extensions/Manifest
@@ -1 +1,2 @@
+DIST mypy_extensions-0.4.3.gh.tar.gz 5545 BLAKE2B 8f1f988562390ee1ba3d90cafafec73c6fe080eef6b4321252d3b3aeffebf1ad13bdcae7ae75c69eac7bef91dcf3f846ae7f9a3f2ad6bad9de2bc8cfe5eed29f SHA512 22d8dc538cf6f77d97f4113dd34fce8095dd98944c7613fab2b3e71a3e9b7df1374654af41ead5c934f789ef1b72f54d980ab06f3ca28b8b4c6bb14ba1ca3ce2
DIST mypy_extensions-0.4.3.tar.gz 5545 BLAKE2B 8f1f988562390ee1ba3d90cafafec73c6fe080eef6b4321252d3b3aeffebf1ad13bdcae7ae75c69eac7bef91dcf3f846ae7f9a3f2ad6bad9de2bc8cfe5eed29f SHA512 22d8dc538cf6f77d97f4113dd34fce8095dd98944c7613fab2b3e71a3e9b7df1374654af41ead5c934f789ef1b72f54d980ab06f3ca28b8b4c6bb14ba1ca3ce2
diff --git a/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..06fdf0d9dc12
--- /dev/null
+++ b/dev-python/mypy_extensions/mypy_extensions-0.4.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Optional static typing for Python"
+HOMEPAGE="
+ http://www.mypy-lang.org/
+ https://github.com/python/mypy_extensions/"
+SRC_URI="
+ https://github.com/python/mypy_extensions/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # This test assumes we get a TypeError, but that is no longer true in 3.11
+ "tests/testextensions.py::TypedDictTests::test_typeddict_errors"
+)
+
+python_test() {
+ epytest tests/*
+}