summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-03 09:00:09 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-03 10:09:08 +0100
commit7c7c31f2c98814a58d7a2e382d951d0b27fd3c3b (patch)
treee032fc669befc5f7c9c8d838b32f54eae74922c0 /dev-python/multidict
parentdev-python/mkdocs_pymdownx_material_extras: Bump to 2.3.1 (diff)
downloadgentoo-7c7c31f2c98814a58d7a2e382d951d0b27fd3c3b.tar.gz
gentoo-7c7c31f2c98814a58d7a2e382d951d0b27fd3c3b.tar.bz2
gentoo-7c7c31f2c98814a58d7a2e382d951d0b27fd3c3b.zip
dev-python/multidict: Bump to 6.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/multidict')
-rw-r--r--dev-python/multidict/Manifest1
-rw-r--r--dev-python/multidict/multidict-6.0.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/multidict/Manifest b/dev-python/multidict/Manifest
index 8fee64a96967..635a6d7e5703 100644
--- a/dev-python/multidict/Manifest
+++ b/dev-python/multidict/Manifest
@@ -1 +1,2 @@
DIST multidict-6.0.2.tar.gz 56840 BLAKE2B 1fa9b0d92a94ed022849a851f925e132b629216ddd0d5d4772304fd3361a129692f8b49fca2765118ab1cbc306879924d0aa7c6b57b648158a093a9f311a8d30 SHA512 508f18c5f731e7438bc7cb84b29aff22422769a8ea4c0ba7c875361d1bb1da78bed2db8b4ca34b833effd03ca3e7f00dabaad64bfce54b3e8d208cdc808083c9
+DIST multidict-6.0.3.gh.tar.gz 58568 BLAKE2B b89373a74c6fb4965bc794e7351d6e9563f810ecdb738000ae5573c8b4717f39c4866fd945c9de2afed4f48060ba675d449d7df512c58d5f34b55bc0d8d44ae9 SHA512 95aef45378c0af6ef6b05549d7419ff4ba272430edae37b2fc041a4742d58890ba9475648b8b5ac57d2bff3718519a0201819b274a65ac0b101cf41c8abad812
diff --git a/dev-python/multidict/multidict-6.0.3.ebuild b/dev-python/multidict/multidict-6.0.3.ebuild
new file mode 100644
index 000000000000..696e10cbe380
--- /dev/null
+++ b/dev-python/multidict/multidict-6.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="multidict implementation"
+HOMEPAGE="
+ https://github.com/aio-libs/multidict/
+ https://pypi.org/project/multidict/
+"
+SRC_URI="
+ https://github.com/aio-libs/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ >=dev-python/cython-0.28.4[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't enable coverage or other pytest settings
+ sed -i -e 's:--cov.*::' setup.cfg || die
+
+ distutils-r1_python_prepare_all
+}