summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-25 09:00:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-25 09:11:42 +0100
commite200316384bb1e856c769007916929fa5cf57a09 (patch)
treeec6fd99e5166ffb664f9b3be05e90d54a6e7a841 /dev-python/msgpack
parentdev-python/charset_normalizer: Bump to 2.0.8 (diff)
downloadgentoo-e200316384bb1e856c769007916929fa5cf57a09.tar.gz
gentoo-e200316384bb1e856c769007916929fa5cf57a09.tar.bz2
gentoo-e200316384bb1e856c769007916929fa5cf57a09.zip
dev-python/msgpack: Bump to 1.0.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest1
-rw-r--r--dev-python/msgpack/msgpack-1.0.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index 31a965d94ab9..ec34bd494c9d 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,2 +1,3 @@
DIST msgpack-0.6.2.tar.gz 119062 BLAKE2B 6b20a0d31b811ae66e66dbfaacec6f0cf2152b2937423b78f3e6244bfa49c87767788c5ee1db41b9020801b8777a4c15b1fe1853182718adf622bc7e1bff858e SHA512 95b92e3d35e0500dd4256d18bf76e586e57cc66319b4459ac5daef599277a5049177a89ad86e291dbdc4c7a918901a89d9218353ddc4a7d0b399e8a98afef363
DIST msgpack-1.0.2.tar.gz 123033 BLAKE2B 8ecf743f5cae536bde9328974827e48376fdfbcaf4d3493fe295a114fd0de4c7dc2629d67a0abf6ece036131715587d2eeaefde0ea9614779a64015ea7fc2be8 SHA512 afe658c2cd5b443aae8fc3305eb3fd56811130062f95e283e3538cba27949d534de60171a927426fedb23b48a938de3f15d77057beda6c73e5204ef1130cd046
+DIST msgpack-1.0.3.tar.gz 123830 BLAKE2B 308af03206fef18edb0acd3c1d91ccd28385731c02cb930e8f64786bbcd8925510cf4ca0b924830b84fd6eaa7edf91e6a43f79c77d856651768eeaa1ab8cf855 SHA512 1569e42c6499c60458a63aa722b5c7e3dc817e38ae4bed2dc8199dc1bcbc36ff876e055b046b4f6063b5606036ae9238080c05be1e09a61a34e7f97fd5031fcd
diff --git a/dev-python/msgpack/msgpack-1.0.3.ebuild b/dev-python/msgpack/msgpack-1.0.3.ebuild
new file mode 100644
index 000000000000..cf8b14db676e
--- /dev/null
+++ b/dev-python/msgpack/msgpack-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="MessagePack (de)serializer for Python"
+HOMEPAGE="https://msgpack.org
+ https://github.com/msgpack/msgpack-python/
+ https://pypi.org/project/msgpack/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~x64-macos"
+IUSE="+native-extensions"
+
+# extension code is relying on CPython implementation details
+BDEPEND="
+ native-extensions? (
+ $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
+ )
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Remove pre-generated cython files
+ rm msgpack/_cmsgpack.cpp || die
+
+ if ! use native-extensions ; then
+ sed -i -e "/have_cython/s:True:False:" setup.py || die
+ fi
+ distutils-r1_python_prepare_all
+}