summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 06:53:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 07:07:12 +0200
commit0a5d5a3a832cd3d8df34d0d3f2e0b3f3100059b6 (patch)
tree3a36a718874679dff6ceca2f3762110ca0283c93 /dev-python/mkdocs-git-authors-plugin
parentdev-python/braintree: Bump to 4.20.0 (diff)
downloadgentoo-0a5d5a3a832cd3d8df34d0d3f2e0b3f3100059b6.tar.gz
gentoo-0a5d5a3a832cd3d8df34d0d3f2e0b3f3100059b6.tar.bz2
gentoo-0a5d5a3a832cd3d8df34d0d3f2e0b3f3100059b6.zip
dev-python/mkdocs-git-authors-plugin: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/Manifest1
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/Manifest b/dev-python/mkdocs-git-authors-plugin/Manifest
index 16b37aee26f0..386dd83ef78f 100644
--- a/dev-python/mkdocs-git-authors-plugin/Manifest
+++ b/dev-python/mkdocs-git-authors-plugin/Manifest
@@ -1 +1,2 @@
DIST mkdocs-git-authors-plugin-0.7.0.gh.tar.gz 28526 BLAKE2B 876b273b476d10f037053ac8c4892f9225b514bfedecd26a7a9dcfd067609c5458fa4c2ed741048092c88dfcda196eab035e4909d3a8184579971273401cbf7c SHA512 aa92a5b49c4f02ea1c4eb5242fc585a341f837e7ebb27a450d703a170fb5e2e9ea5b04e2c6f121747300d86ac5fc0e69a553e1d7b02786e8fd6cd4943cbec6c2
+DIST mkdocs-git-authors-plugin-0.7.1.gh.tar.gz 28974 BLAKE2B aea1a6d844aaf4ecd9b94d5cb62bfb59206838f825a96431f123e2706eb44f371cb893e45f0b5311ad2a47403b3be0e896383b3be7ab92a5a4b45d873bbc1370 SHA512 0de4ab85de1b1803ef6410bbeffb7f4ae03b6ce5aa1d9c3926004144c037193765b4e1d02560960fd6954f2f887694345c19dcdeea17cabf6a51fcb0b7120243
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.1.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.1.ebuild
new file mode 100644
index 000000000000..2c5e16a6a392
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.7.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..11} )
+
+# Requires self to be installed to build docs
+# TODO: Do this a bit better
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="
+ dev-python/regex
+ dev-python/mkdocs-material
+ dev-python/mkdocs-git-authors-plugin
+"
+DOCS_INITIALIZE_GIT=1
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+# Tests are broken outside of upstream git repo
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ use test && initialize_git_repo
+
+ distutils-r1_python_prepare_all
+}