summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-09-19 11:24:32 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-09-19 11:24:32 -0400
commit0fe68a60852a6935b9d93bca2c5708409f963d3e (patch)
tree02de5219d3a01f19b51f7fcc97112a5a93a35ff9 /dev-python/mistune
parentapp-eselect/eselect-infinality: amd64 stable (bug #666378) (diff)
downloadgentoo-0fe68a60852a6935b9d93bca2c5708409f963d3e.tar.gz
gentoo-0fe68a60852a6935b9d93bca2c5708409f963d3e.tar.bz2
gentoo-0fe68a60852a6935b9d93bca2c5708409f963d3e.zip
dev-python/mistune: vump to 0.8.3
Bug: https://bugs.gentoo.org/639298 Bug: https://bugs.gentoo.org/635270 Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python/mistune')
-rw-r--r--dev-python/mistune/Manifest1
-rw-r--r--dev-python/mistune/mistune-0.8.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/mistune/Manifest b/dev-python/mistune/Manifest
index 7957dc072e88..1b83d62e5b04 100644
--- a/dev-python/mistune/Manifest
+++ b/dev-python/mistune/Manifest
@@ -1,2 +1,3 @@
DIST mistune-0.7.2.tar.gz 48887 BLAKE2B 4ff0286483e593fcf5183bfed18b90c39b93dacdec3bba474d6959ec1da162dd75820707a8ed9985fff4c15fe88a12df6fb6af20b9a40de173acd7c0a6e02893 SHA512 9002bf83a368671389f05928f4f689064a1e415e54309259b6bbb7781b4bfddbbf834e2c63ed3271e1e6ec7b78c1665c7708177b9723433d1e2ad4b13ad903ca
DIST mistune-0.7.4.tar.gz 49304 BLAKE2B 9426007f618e645832d4d73db29cdda63e8426c9e52bda06935b0003b3c4f0122b14ca893ef4adad96c7d2f4b8be777efb6862f5370bdb9b08394129fd22e7d0 SHA512 d300bec23f5482396c6f282ee3d773461c162791e4605ca40141eb9487c8b158ac7f47f6338f7c3bf27bc614292ecc61dfbf419d47eab817821f18cf80103802
+DIST mistune-0.8.3.tar.gz 58506 BLAKE2B a4b96162514ba1b82710c9264d9005f151943d525ff7e28a2fd4a92b16d4c90818715bf851573e25be203537a3059dbec1e86c75ec0ebd0a4b164303c06d7029 SHA512 fc0b6d53e7a62712b752bff77c2529750628e9e1eeec02603bd2c793f9b0a46efe31fe7a749c5d6aae3c591d74e43c45e450179650bfb57128fb0ec366de6aa3
diff --git a/dev-python/mistune/mistune-0.8.3.ebuild b/dev-python/mistune/mistune-0.8.3.ebuild
new file mode 100644
index 000000000000..91180abbb647
--- /dev/null
+++ b/dev-python/mistune/mistune-0.8.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The fastest markdown parser in pure Python"
+HOMEPAGE="https://pypi.org/project/mistune/ https://github.com/lepture/mistune"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+BDEPEND="
+ dev-python/cython[$(python_gen_usedep 'python*')]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ nosetests || die
+}