summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-06 17:18:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-06 17:29:44 +0200
commit5084c3f60a5d39bf78bf5c4c98a6358850e2187e (patch)
tree343c667d9cc30f5e37b5d97b9f2d8ec5a2345622 /dev-python/minify-html
parentdev-libs/libclc: Extend LLVM_COMPAT to include 18 in 18+ (diff)
downloadgentoo-5084c3f60a5d39bf78bf5c4c98a6358850e2187e.tar.gz
gentoo-5084c3f60a5d39bf78bf5c4c98a6358850e2187e.tar.bz2
gentoo-5084c3f60a5d39bf78bf5c4c98a6358850e2187e.zip
dev-python/minify-html: Prevent implicit stripping
Closes: https://bugs.gentoo.org/931304 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/minify-html')
-rw-r--r--dev-python/minify-html/minify-html-0.15.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/minify-html/minify-html-0.15.0.ebuild b/dev-python/minify-html/minify-html-0.15.0.ebuild
index be94da626d42..cc27edc8ca71 100644
--- a/dev-python/minify-html/minify-html-0.15.0.ebuild
+++ b/dev-python/minify-html/minify-html-0.15.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -38,3 +38,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm64"
QA_FLAGS_IGNORED="usr/lib.*/py.*/site-packages/minify_html/minify_html.*.so"
+
+src_prepare() {
+ sed -i -e '/strip/d' Cargo.toml || die
+ distutils-r1_src_prepare
+}