summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-09-13 11:57:02 +0200
committerSam James <sam@gentoo.org>2022-09-14 23:28:45 +0100
commit6e0866263b8c34b90fbdaccdcaf419803ff19d4a (patch)
treedc56d5fba2e1d7f1ac30fecd6088cfd182578350 /dev-python/matrix-common
parentapp-text/aha: Keyword 0.5.1 riscv, #870103 (diff)
downloadgentoo-6e0866263b8c34b90fbdaccdcaf419803ff19d4a.tar.gz
gentoo-6e0866263b8c34b90fbdaccdcaf419803ff19d4a.tar.bz2
gentoo-6e0866263b8c34b90fbdaccdcaf419803ff19d4a.zip
dev-python/matrix-common: add 1.3.0
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/matrix-common')
-rw-r--r--dev-python/matrix-common/Manifest1
-rw-r--r--dev-python/matrix-common/matrix-common-1.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/matrix-common/Manifest b/dev-python/matrix-common/Manifest
index 8f3aea5f9006..179e385e85e0 100644
--- a/dev-python/matrix-common/Manifest
+++ b/dev-python/matrix-common/Manifest
@@ -1 +1,2 @@
DIST matrix-common-1.2.1.gh.tar.gz 12598 BLAKE2B 94f25d90c9df948054739cee39033c1f261e61300aa74b7ce606cf8a3c82e716687aa57ddb0f72b8617ae56c21486b50a68f9e6c8611e2f8b19c33b0d2a557e7 SHA512 9ab05d6aeddf4915970916d34e625b7a059823e56ba8868f955cf8971a51ac31891304a7fb00170c60c6b107f7526565f67bd78416a466c50092954c5b422114
+DIST matrix-common-1.3.0.gh.tar.gz 14143 BLAKE2B dd72a7c5558c2db0ab38f2f544f6ab6926fd037e99cbb774973f08bdc661c1587d3d6883ffc6a9cfcea6942284d4020814c02d56be3746279323fca17490f434 SHA512 d08fa11a4156a7c4596ea20709e0fddd1563ef1f4ba763e21a073ba53e1baf58d8de1b60cf0f69c846128cdd6f04788df49765704c8adfde187e8de1dc5ded4e
diff --git a/dev-python/matrix-common/matrix-common-1.3.0.ebuild b/dev-python/matrix-common/matrix-common-1.3.0.ebuild
new file mode 100644
index 000000000000..f3bd4f3f339c
--- /dev/null
+++ b/dev-python/matrix-common/matrix-common-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Common code for Synapse, Sydent and Sygnal"
+HOMEPAGE="
+ https://github.com/matrix-org/matrix-python-common
+ https://pypi.org/project/matrix-common/
+"
+SRC_URI="
+ https://github.com/matrix-org/matrix-python-common/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+S="${WORKDIR}/matrix-python-common-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest