summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2023-05-24 16:59:09 -0500
committerMatthias Maier <tamiko@gentoo.org>2023-05-25 20:04:32 -0500
commit2f841741e2f615652aa73bdc6cb435ec572a5ae6 (patch)
tree756bbd90185de8b26b63946f9746a240e5194459 /dev-python/magic-wormhole
parentdev-python/noiseprotocol: new package, add 0.3.1 (diff)
downloadgentoo-2f841741e2f615652aa73bdc6cb435ec572a5ae6.tar.gz
gentoo-2f841741e2f615652aa73bdc6cb435ec572a5ae6.tar.bz2
gentoo-2f841741e2f615652aa73bdc6cb435ec572a5ae6.zip
dev-python/magic-wormhole: new package, add 0.12.0_p20230525
Revision: - move to latest upstream patches for python 3.11 support - enable testsuite - verified that the package installs cleanly for 3.10 and 3.11 Bug: https://bugs.gentoo.org/907117 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/magic-wormhole')
-rw-r--r--dev-python/magic-wormhole/Manifest1
-rw-r--r--dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild51
-rw-r--r--dev-python/magic-wormhole/metadata.xml13
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole/Manifest b/dev-python/magic-wormhole/Manifest
new file mode 100644
index 000000000000..95132edb3b84
--- /dev/null
+++ b/dev-python/magic-wormhole/Manifest
@@ -0,0 +1 @@
+DIST magic-wormhole-0.12.0_p20230525.gh.tar.gz 281332 BLAKE2B daf9e39c89d8591584b25f142de2e66757a31970179f38e2fb74e112295e637f94930127bd3c0c1cc1243ac559dc4885bab3e7892b112dbf174b0514b49051c0 SHA512 ef5be6396fb9d6e35c64baeeaaea269526f9f8127eaf1bdd7b7b693a0272885388c4d6dc9fac87f6355eff5e9fe94450aebeafd2009b7d74f6772922a2796cbd
diff --git a/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild b/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild
new file mode 100644
index 000000000000..6a6c99bff5a9
--- /dev/null
+++ b/dev-python/magic-wormhole/magic-wormhole-0.12.0_p20230525.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+# Version 0.12.0 with additional upstream fixes for python 3.11 support and
+# miscellanous improvements
+COMMIT_SHA1="8af8888d171791943b9fab036f0e0067b87c9b59"
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Get Things From One Computer To Another, Safely"
+HOMEPAGE="https://magic-wormhole.readthedocs.io/en/latest/ https://pypi.org/project/magic-wormhole/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT_SHA1}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${P}.gh"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/automat[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ dev-python/noiseprotocol[${PYTHON_USEDEP}]
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/spake2[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+ dev-python/txtorcon[${PYTHON_USEDEP}]"
+
+#
+# magic-wormhole-0.12.0_p20230525 requires the released
+# magic-wormhole-transit-relay-0.21 for setting up its unit tests. This
+# hopefully will be resolved soon with the upcoming releases (of wormhole,
+# mailbox-server, and transit-relay).
+#
+BDEPEND="
+ test? (
+ dev-python/magic-wormhole-mailbox-server[${PYTHON_USEDEP}]
+ ~dev-python/magic-wormhole-transit-relay-0.2.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
diff --git a/dev-python/magic-wormhole/metadata.xml b/dev-python/magic-wormhole/metadata.xml
new file mode 100644
index 000000000000..c0b4cfe14855
--- /dev/null
+++ b/dev-python/magic-wormhole/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tamiko@gentoo.org</email>
+ <name>Matthias Maier</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">magic-wormhole</remote-id>
+ <remote-id type="github">magic-wormhole/magic-wormhole</remote-id>
+ </upstream>
+</pkgmetadata>