summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-10 04:10:00 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-10 04:10:00 +0100
commit6f9356e30b6f82eeb2030843566a9da756bfc8f0 (patch)
treedd4e3b67a8d5831853d261931c0b430449577cc6 /dev-python/magic-wormhole-mailbox-server
parentdev-python/netcdf4: Remove old (diff)
downloadgentoo-6f9356e30b6f82eeb2030843566a9da756bfc8f0.tar.gz
gentoo-6f9356e30b6f82eeb2030843566a9da756bfc8f0.tar.bz2
gentoo-6f9356e30b6f82eeb2030843566a9da756bfc8f0.zip
dev-python/magic-wormhole-mailbox-server: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/magic-wormhole-mailbox-server')
-rw-r--r--dev-python/magic-wormhole-mailbox-server/Manifest1
-rw-r--r--dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.5.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/magic-wormhole-mailbox-server/Manifest b/dev-python/magic-wormhole-mailbox-server/Manifest
index 4e01b0978cf1..96f52bdf28f8 100644
--- a/dev-python/magic-wormhole-mailbox-server/Manifest
+++ b/dev-python/magic-wormhole-mailbox-server/Manifest
@@ -1,2 +1,3 @@
DIST magic-wormhole-mailbox-server-0.5.0.tar.gz 69683 BLAKE2B 726f3ee155bafa3d6c5c60cf91c987725abd24b7e4e5842ddd08b0c1c0a66d1cd1bf453dd3384295226e26838def5b6720a3ed0906ff1090acee24b7eb724288 SHA512 604b7c03eb95c1de38fba511cc2eb2a7b19bf4cb2dd8cdfab956f3b6d79c141b9c966f3bf8a1362a1eba4006eefb5fe48a9262830389d51ec711fd7c1cfc9891
+DIST magic-wormhole-mailbox-server-0.5.1.tar.gz 69758 BLAKE2B 5dfb21f1e3994cdef9c510b2e265393e8200711fde3d3e6759783d55b1b11b32b291c774d04a0930cc537b3bb599598588c48e382e35642f856e738b832be442 SHA512 6a3345c8d18c2373dee5c748f6fa1437f7225d057b136439ba7bebfd3b55a7a1beb551357b66b1847cfa0c73bed87a136844c907432ccc045c6f9b528698d7b8
DIST magic-wormhole-mailbox-server-30ecb6e3f6f487c915e7ff0acdf2e630cbe17dc8.gh.tar.gz 73753 BLAKE2B 91a6059f19aafe74416df7bf43dbd27ff333950bf315e0e5c1ab83b696a6ea074d239db4127a6aaf171cc1a31d566439508dafbd8d4eba52729af0c981325f58 SHA512 4d0f2a8a74a7ba2c3f0635af4d4e44485df81858207eba1e3d0c0c1dea7554dedb653ee69ea82e220f0fedfe553e461feb047f3faa83cff613f0d9745a85aed9
diff --git a/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.5.1.ebuild b/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.5.1.ebuild
new file mode 100644
index 000000000000..a7c9165685eb
--- /dev/null
+++ b/dev-python/magic-wormhole-mailbox-server/magic-wormhole-mailbox-server-0.5.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Mailbox server for magic-wormhole"
+HOMEPAGE="
+ https://magic-wormhole.readthedocs.io/en/latest/
+ https://github.com/magic-wormhole/magic-wormhole-mailbox-server/
+ https://pypi.org/project/magic-wormhole-mailbox-server/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/autobahn[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/twisted[ssl,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/treq[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm versioneer.py || die
+}