summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-04 18:14:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-04 18:17:34 +0200
commit9548e1078eacfeb3661d449700fe467655f674d0 (patch)
tree37501be647895eb9fd1f9152bfef5190a80fb7b8 /dev-python/libvirt-python
parentdev-python/libsass: Set DISTUTILS_EXT=1 (diff)
downloadgentoo-9548e1078eacfeb3661d449700fe467655f674d0.tar.gz
gentoo-9548e1078eacfeb3661d449700fe467655f674d0.tar.bz2
gentoo-9548e1078eacfeb3661d449700fe467655f674d0.zip
dev-python/libvirt-python: Set DISTUTILS_EXT=1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/libvirt-python-9.2.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild
index 25f4ff942c9e..e097973cb8b7 100644
--- a/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild
+++ b/dev-python/libvirt-python/libvirt-python-9.2.0.ebuild
@@ -10,10 +10,9 @@ EAPI=8
# app-emulation/libvirt
# Please bump them together!
-PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=setuptools
-MY_P="${P/_rc/-rc}"
-VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libvirt.org.asc
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 verify-sig
if [[ ${PV} == *9999* ]]; then
@@ -21,6 +20,7 @@ if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
RDEPEND="app-emulation/libvirt:="
else
+ MY_P="${P/_rc/-rc}"
SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz
verify-sig? ( https://libvirt.org/sources/python/${MY_P}.tar.gz.asc )"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
@@ -44,6 +44,8 @@ BDEPEND="
verify-sig? ( sec-keys/openpgp-keys-libvirt )
"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libvirt.org.asc
+
distutils_enable_tests pytest
python_install_all() {