summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-16 04:28:43 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-16 04:28:43 +0100
commitebd4fef2f6c858d70f57115783ac6c154d223b15 (patch)
treea9af23398403b5f423a446a6d34f9252c94233f2 /dev-python/libtmux
parentdev-python/pyotherside: Bump to 1.6.2 (diff)
downloadgentoo-ebd4fef2f6c858d70f57115783ac6c154d223b15.tar.gz
gentoo-ebd4fef2f6c858d70f57115783ac6c154d223b15.tar.bz2
gentoo-ebd4fef2f6c858d70f57115783ac6c154d223b15.zip
dev-python/libtmux: Bump to 0.43.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.43.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 88f068299010..3a5f2c97fd9a 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -6,3 +6,4 @@ DIST libtmux-0.40.0.gh.tar.gz 317064 BLAKE2B e3658560a789aa823faf2ff29cca3a0604e
DIST libtmux-0.40.1.gh.tar.gz 318542 BLAKE2B 5b9e383a3c07bab3af7c25adcf5db1c6acf1c108a2508aa2de5f6c2db64f1e365829c69299568c39a19a7c18aa773b14033aa0c48087d0d1bcf180377df558f6 SHA512 6e4f0d13b375ca1b2c2f6e7c6aaad6d420927c8d55a2f27e7912738a58a7e9f0db67c84936ccff32c9557ebe1f3ac335e779b293466eaab9333a0e3fb4a4b10e
DIST libtmux-0.42.0.gh.tar.gz 318655 BLAKE2B 5d462bd78e81bd38cfb0c42a2100287fc79b9fe31aaeccbac5c9fd124afc2df9da4ceb5cd469de1919df2995c27d4c0628629004938795b6f8731e84c23ed2bc SHA512 38e7c21bd99859add1737a1028c18852a564a2d32c27b72ea37d623bcbc0646b095ad4dd520385c11d6df4c779429ac452f6ae592a6d0ffcb4fe64bf2a4388b3
DIST libtmux-0.42.1.gh.tar.gz 318887 BLAKE2B 7bbac22a4d2aa0a448888777b2ce99b08a90b5a76907f95ffe5278d3fb87354ae7bab5ab6b5b21ff7485b656ae6efd5a70f968750009bda2b8959024aefb3538 SHA512 a8f2be99f7e7b20d78c4597cd588571481247d1cfff4dbecaa93322584f56099a966ee745a192231ace92cd29d48232922b3b15445115039f21aca8cd33c6d69
+DIST libtmux-0.43.0.gh.tar.gz 322128 BLAKE2B 835e6d4bf47c54a7cc373ad54e11bd49aba84b19e68dea20b73c977e145396a89cf7562861c75eed5fdedcfc69f83855786aa88139a2f88dee29a272cdbc1f1d SHA512 1a2992fc6d65811bb7d42e2d5eecc7efe9cf737fcd5898ed91e4f4cf317244e7a5f14fa21ea1a169dd3f8fbad8bf044e371f26704a091d7d22465ce410105220
diff --git a/dev-python/libtmux/libtmux-0.43.0.ebuild b/dev-python/libtmux/libtmux-0.43.0.ebuild
new file mode 100644
index 000000000000..28f00ece7486
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.43.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typed library that provides an ORM wrapper for tmux, a terminal multiplexer"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests/test_window.py::test_fresh_window_data fails if TMUX_PANE is set
+ # https://bugs.gentoo.org/927158
+ local -x TMUX_PANE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=libtmux.pytest_plugin
+
+ epytest -o addopts= -p pytest_mock -p rerunfailures --reruns=5 tests
+}