summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-13 20:12:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-13 20:42:02 +0100
commit6d075a9d8bef74adbbc4feb5e62ffcff1ba51b27 (patch)
tree1cb0b9de556de208475bb2fcec007fe85f00759c /dev-python/libsass
parentdev-python/virtualenv: Bump to 20.16.7 (diff)
downloadgentoo-6d075a9d8bef74adbbc4feb5e62ffcff1ba51b27.tar.gz
gentoo-6d075a9d8bef74adbbc4feb5e62ffcff1ba51b27.tar.bz2
gentoo-6d075a9d8bef74adbbc4feb5e62ffcff1ba51b27.zip
dev-python/libsass: Bump to 0.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libsass')
-rw-r--r--dev-python/libsass/Manifest1
-rw-r--r--dev-python/libsass/libsass-0.22.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/libsass/Manifest b/dev-python/libsass/Manifest
index ab82a1ada608..ce06c29ba660 100644
--- a/dev-python/libsass/Manifest
+++ b/dev-python/libsass/Manifest
@@ -1 +1,2 @@
DIST libsass-python-0.21.0.gh.tar.gz 55774 BLAKE2B 3c584ff3b6c09bc768554a3a4f7ef28ecea0726f59206da8540f9c1b4db74ab1235695074dd6b95db74f174066bb856c9854026525da82e7763f341920f0bd53 SHA512 d5b7a1bf0dc736a6a38e2e609f0a213306de31d5ad84cfdcd96f9ff72a1c38f15bad3cf25a1cec6dca5a9f3b00a8509afff2b4ea5e4db80e218e3ae603d55856
+DIST libsass-python-0.22.0.gh.tar.gz 55135 BLAKE2B 8495462fa8e6a68bf73ecdf68771c577bad1affa1121c1781dac41c912aae731df88c2b1d1a4ef363e50a98ff1b471e7c45562faa6f2425e8ec5f47f9cf76c6c SHA512 13914b60fe19fc70d197a948a2bc83f7646e4acaa45caed6df68bf2eb10e0a7ef811cdbbcc7a4338f9c1433cba8e316146c20072dc4ff34f51e094ead1bfdcd7
diff --git a/dev-python/libsass/libsass-0.22.0.ebuild b/dev-python/libsass/libsass-0.22.0.ebuild
new file mode 100644
index 000000000000..895dfea5ba99
--- /dev/null
+++ b/dev-python/libsass/libsass-0.22.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+MY_P="libsass-python-${PV}"
+DESCRIPTION="A straightforward binding of libsass for Python"
+HOMEPAGE="
+ https://github.com/sass/libsass-python/
+ https://pypi.org/project/libsass/
+"
+SRC_URI="
+ https://github.com/sass/libsass-python/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ >=dev-libs/libsass-3.6.5
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? (
+ dev-python/PyQt5[testlib,${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ echo "${PV}" > .libsass-upstream-version || die
+ distutils-r1_src_prepare
+ export SYSTEM_SASS=1
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # probably broken by removal of sassc
+ sasstests.py::SasscTestCase::test_sassc_stdout
+ # skip the pip tests because they need an internet connection
+ # not relevant for gentoo anyway
+ sasstests.py::DistutilsTestCase::test_build_sass
+ sasstests.py::DistutilsTestCase::test_output_style
+ )
+
+ epytest sasstests.py
+}