summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-07 18:23:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-07 18:23:25 +0100
commitaa2a27f8f81d5f077b547d35068fc961a70dedf0 (patch)
tree567e21e2ebe1ed939a430381b82c5e47485364eb /dev-python/kiwisolver
parentnet-news/rssguard: Remove 4.6.0 (diff)
downloadgentoo-aa2a27f8f81d5f077b547d35068fc961a70dedf0.tar.gz
gentoo-aa2a27f8f81d5f077b547d35068fc961a70dedf0.tar.bz2
gentoo-aa2a27f8f81d5f077b547d35068fc961a70dedf0.zip
dev-python/kiwisolver: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch30
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild45
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index 8fc3163399dd..cead14b39286 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1,2 +1 @@
-DIST kiwi-1.4.4.gh.tar.gz 91343 BLAKE2B a5e345509e7294eaf89e1361c035b3ef5d672d335682dbb426196d22876762b1f729cc728300f731a42afbfdf2828591f83cc53daf28e8d4c451a1b246b4800f SHA512 9a7ed487bb28f8c430543dc21ea59156078c129fd29b1382f1578368e72f312f4e813eb4501e4c9387647b42b085b93d4bd27d0e846f1396fa4ce68fd9e9ba5f
DIST kiwi-1.4.5.gh.tar.gz 91741 BLAKE2B cebdf8269b063d10f85a303cf5fa850f87c911aff9be37ae2b6762f021ea25b8b8cb3759e7e4292bc8c2fdbdf5d73ef6295263f541adb283969509cc11d8428a SHA512 889e106c27915cb773bc13969605812c1ca01a139e992d2b3517eb20989ae41392bfdcdd63184a7777b13eff5109d167869087ea09149b1527e56a3455213b14
diff --git a/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch b/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
deleted file mode 100644
index 705855f02f61..000000000000
--- a/dev-python/kiwisolver/files/kiwisolver-1.4.4-pypy3-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Patch provided upstream as https://github.com/nucleic/kiwi/pull/158
-from issue created at https://github.com/nucleic/kiwi/issues/157
-
-commit ad1c62f046dc14c1e85e4e1c1b8e175eda08838e
-Author: Jérôme Carretero <cJ-kiwisolver@zougloub.eu>
-Date: Fri Feb 17 18:40:45 2023 -0500
-
- py: tests: make tests run under PyPy
-
-diff --git a/py/tests/test_expression.py b/py/tests/test_expression.py
-index 671dd7f..6b5d8e5 100644
---- a/py/tests/test_expression.py
-+++ b/py/tests/test_expression.py
-@@ -8,6 +8,7 @@
- import gc
- import math
- import operator
-+import sys
- from typing import Tuple
-
- import pytest
-@@ -264,4 +265,7 @@ def test_expression_rich_compare_operations(op, symbol) -> None:
- else:
- with pytest.raises(TypeError) as excinfo:
- op(e1, e2)
-- assert "kiwisolver.Expression" in excinfo.exconly()
-+ if "PyPy" in sys.version:
-+ assert "Expression" in excinfo.exconly()
-+ else:
-+ assert "kiwisolver.Expression" in excinfo.exconly()
diff --git a/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild b/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
deleted file mode 100644
index 96b90cf0ac22..000000000000
--- a/dev-python/kiwisolver/kiwisolver-1.4.4-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1
-
-MY_P=kiwi-${PV}
-DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
-HOMEPAGE="
- https://github.com/nucleic/kiwi/
- https://pypi.org/project/kiwisolver/
-"
-SRC_URI="
- https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Clear-BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86 ~arm64-macos ~x64-macos"
-
-COMMON_DEPEND="
- >=dev-python/cppy-1.2.0[${PYTHON_USEDEP}]
-"
-
-RDEPEND="
- ${COMMON_DEPEND}
-"
-BDEPEND="
- ${COMMON_DEPEND}
- >=dev-python/setuptools-scm-3.4.3[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.4.4-pypy3-tests.patch"
-)
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}