summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 07:48:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 08:21:48 +0200
commit319045d3171465b3a70e85bb98d86897137ca8bc (patch)
treeb0c27bbe0c3726e06c48fc6c14aa24d72ed95e87 /dev-python/jupyter-console
parentRename dev-python/{jupyter_ydoc → jupyter-ydoc} (diff)
downloadgentoo-319045d3171465b3a70e85bb98d86897137ca8bc.tar.gz
gentoo-319045d3171465b3a70e85bb98d86897137ca8bc.tar.bz2
gentoo-319045d3171465b3a70e85bb98d86897137ca8bc.zip
Rename dev-python/{jupyter_console → jupyter-console}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jupyter-console')
-rw-r--r--dev-python/jupyter-console/Manifest1
-rw-r--r--dev-python/jupyter-console/jupyter-console-6.6.3.ebuild40
-rw-r--r--dev-python/jupyter-console/metadata.xml21
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/jupyter-console/Manifest b/dev-python/jupyter-console/Manifest
new file mode 100644
index 000000000000..fac2c631a7dd
--- /dev/null
+++ b/dev-python/jupyter-console/Manifest
@@ -0,0 +1 @@
+DIST jupyter_console-6.6.3.tar.gz 34363 BLAKE2B fd5875f608bec0528f7751b7cb146bff3f5c6caeb531a360eb5dd6164c44b3a4a84d1371756f42c256fbada7572176172894a01bc5b7cca835f12a390815ff5a SHA512 fc896dfc783648127690458712e90eced9578629dd55e3bfc9e15319ffa919c118c78d7872f0274455c3996fa9321bccdfa204b94b45a2de733b7703894c9034
diff --git a/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild b/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild
new file mode 100644
index 000000000000..8709fe346234
--- /dev/null
+++ b/dev-python/jupyter-console/jupyter-console-6.6.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A terminal-based console frontend for Jupyter kernels"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/jupyter_console/
+ https://pypi.org/project/jupyter-console/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ dev-python/ipython[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-client-7.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-core-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/prompt-toolkit-3.0.30[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.4[${PYTHON_USEDEP}]
+"
+# util-linux provides script(1)
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ sys-apps/util-linux
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jupyter-console/metadata.xml b/dev-python/jupyter-console/metadata.xml
new file mode 100644
index 000000000000..0d62052f276f
--- /dev/null
+++ b/dev-python/jupyter-console/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ A terminal-based console frontend for Jupyter kernels.
+ This code is based on the single-process IPython terminal.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jupyter-console</remote-id>
+ <remote-id type="github">jupyter/jupyter_console</remote-id>
+ </upstream>
+</pkgmetadata>