summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-17 18:42:15 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-17 18:43:37 +0100
commit6bd789cac61b61ebf78d6ba5be027a77d9571226 (patch)
tree4bb197e79be2347ee8e0c08ca2f5fc00bd1f4be8 /dev-python/jsonrpclib
parentdev-python/jsonmerge: Port up to py3.9 (diff)
downloadgentoo-6bd789cac61b61ebf78d6ba5be027a77d9571226.tar.gz
gentoo-6bd789cac61b61ebf78d6ba5be027a77d9571226.tar.bz2
gentoo-6bd789cac61b61ebf78d6ba5be027a77d9571226.zip
dev-python/jsonrpclib: Port up to py3.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonrpclib')
-rw-r--r--dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild10
1 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
index 3caeeb9a0089..5934ddc40bb5 100644
--- a/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
+++ b/dev-python/jsonrpclib/jsonrpclib-0.4.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
@@ -19,13 +19,7 @@ HOMEPAGE="https://github.com/tcalmant/jsonrpclib"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND} )"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py