summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-04 22:18:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-04 23:09:45 +0100
commitff111693c43ac87929b3ccfcc0fe5599d3c331c0 (patch)
treef70acd1501d1f4b28327f86b9ed641bc504ee2ae /dev-python/jsonpointer
parentdev-python/py: Bump to 1.11.0 (diff)
downloadgentoo-ff111693c43ac87929b3ccfcc0fe5599d3c331c0.tar.gz
gentoo-ff111693c43ac87929b3ccfcc0fe5599d3c331c0.tar.bz2
gentoo-ff111693c43ac87929b3ccfcc0fe5599d3c331c0.zip
dev-python/jsonpointer: Bump to 2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jsonpointer')
-rw-r--r--dev-python/jsonpointer/Manifest1
-rw-r--r--dev-python/jsonpointer/jsonpointer-2.2.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/jsonpointer/Manifest b/dev-python/jsonpointer/Manifest
index 08780dc0bb47..2d9ab06e1016 100644
--- a/dev-python/jsonpointer/Manifest
+++ b/dev-python/jsonpointer/Manifest
@@ -1 +1,2 @@
DIST jsonpointer-2.1.tar.gz 8190 BLAKE2B 5b9d0b0a27c6e2d133de67cf0ff9442e639a06011005f94cb425568fd3e5678b4832e9467720261fb85669e8b83eac73b1cfa8058adbd78d46339cdf8359561c SHA512 4eed8c7fa908ce3ca79884e98b1b0e818d24515f6b7b2067daa49ab6dbd989be4bc43f387e980773c9fc17bca89d2039750cb0df76675259050e3f48c16da3b6
+DIST jsonpointer-2.2.tar.gz 8292 BLAKE2B 837c6c8a87e0d19cbeed07769afb29fa56ddfb629f05d0f2de94f4e94af916358f71892e085c7c18b9c711ac8e604a0ff7d1fa7dfbf52836edb1a600e5ed390b SHA512 ce680e3915ea9db915095c4106e58acf7cc2148bdc67944e03e225a33b882964ed0c154fdbe8415f787c5aa5bfa007b9e1fd2a31689dcadc88b1560931ca6a6d
diff --git a/dev-python/jsonpointer/jsonpointer-2.2.ebuild b/dev-python/jsonpointer/jsonpointer-2.2.ebuild
new file mode 100644
index 000000000000..46bd94469a48
--- /dev/null
+++ b/dev-python/jsonpointer/jsonpointer-2.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Identify specific nodes in a JSON document (according to draft 08)"
+HOMEPAGE="https://github.com/stefankoegl/python-json-pointer https://pypi.org/project/jsonpointer/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+python_test() {
+ "${EPYTHON}" tests.py || die "Tests fail with ${EPYTHON}"
+}