summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-24 07:30:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-24 07:40:09 +0200
commita5364395cdcac15b4106785eeb9dd20f3755ca91 (patch)
tree1d5149c1f745cbe9c43b4036535fab8cecf95509 /dev-python/jschema-to-python
parentwww-client/firefox-bin: drop 118.0.2 (diff)
downloadgentoo-a5364395cdcac15b4106785eeb9dd20f3755ca91.tar.gz
gentoo-a5364395cdcac15b4106785eeb9dd20f3755ca91.tar.bz2
gentoo-a5364395cdcac15b4106785eeb9dd20f3755ca91.zip
Rename dev-python/{jschema_to_python → jschema-to-python}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jschema-to-python')
-rw-r--r--dev-python/jschema-to-python/Manifest1
-rw-r--r--dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild26
-rw-r--r--dev-python/jschema-to-python/metadata.xml12
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jschema-to-python/Manifest b/dev-python/jschema-to-python/Manifest
new file mode 100644
index 000000000000..da7796f56a79
--- /dev/null
+++ b/dev-python/jschema-to-python/Manifest
@@ -0,0 +1 @@
+DIST jschema_to_python-1.2.3.tar.gz 10061 BLAKE2B e6d16ce5950cf787bc2073c5470c304f8d10bf97fdcc53f4ec2dd00f7cc5d6ec1308ef0813ef3eaf5b98a5cd018b43f3ca30abba441c5b1cb9a02783aa596f22 SHA512 e7e37612573e2f5cf96df6fe7206ecf31c83993e40877b0587df2a42ef2f2ae192e4f8442d40cdfb728c27fca880ae5bb427935fa7b0bbd9fadbb9a643c3c1f0
diff --git a/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild b/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..08cc0d5a6fae
--- /dev/null
+++ b/dev-python/jschema-to-python/jschema-to-python-1.2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Generate source code for Python classes from a JSON schema"
+HOMEPAGE="
+ https://pypi.org/project/jschema-to-python/
+ https://github.com/microsoft/jschema-to-python/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/jsonpickle[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
diff --git a/dev-python/jschema-to-python/metadata.xml b/dev-python/jschema-to-python/metadata.xml
new file mode 100644
index 000000000000..61b1962fbb79
--- /dev/null
+++ b/dev-python/jschema-to-python/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">jschema-to-python</remote-id>
+ <remote-id type="github">microsoft/jschema-to-python</remote-id>
+ </upstream>
+</pkgmetadata>