summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-06 16:05:31 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-06 16:15:10 +0200
commit861682b10d028a623b5bb99dcfb1da0dabf05009 (patch)
treecef5d20462eb6f240946f8d5a56d14008816a9a5 /dev-python/jaraco-text
parentdev-libs/wayland-protocols: Version bump to 1.32 (diff)
downloadgentoo-861682b10d028a623b5bb99dcfb1da0dabf05009.tar.gz
gentoo-861682b10d028a623b5bb99dcfb1da0dabf05009.tar.bz2
gentoo-861682b10d028a623b5bb99dcfb1da0dabf05009.zip
dev-python/jaraco-text: Make CLI dependencies optional
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/jaraco-text')
-rw-r--r--dev-python/jaraco-text/jaraco-text-3.11.1.ebuild10
-rw-r--r--dev-python/jaraco-text/metadata.xml5
2 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
index 3c4773fac6e5..4a3217e4b983 100644
--- a/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
+++ b/dev-python/jaraco-text/jaraco-text-3.11.1.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="cli"
RDEPEND="
>=dev-python/jaraco-context-4.1.1-r1[${PYTHON_USEDEP}]
@@ -28,13 +29,18 @@ RDEPEND="
"
# needed only for CLI tool, make it PDEPEND to reduce pain in setuptools
# bootstrap
-PDEPEND="
+CLI_DEPEND="
$(python_gen_cond_dep '
dev-python/autocommand[${PYTHON_USEDEP}]
dev-python/inflect[${PYTHON_USEDEP}]
dev-python/more-itertools[${PYTHON_USEDEP}]
' "${CLI_COMPAT[@]}")
"
+PDEPEND="
+ cli? (
+ ${CLI_DEPEND}
+ )
+"
BDEPEND="
test? (
${PDEPEND}
@@ -65,7 +71,7 @@ src_configure() {
python_test() {
local EPYTEST_IGNORE=()
- if ! has "${EPYTHON/./_}" "${CLI_COMPAT[@]}"; then
+ if ! use cli || ! has "${EPYTHON/./_}" "${CLI_COMPAT[@]}"; then
EPYTEST_IGNORE+=(
jaraco/text/show-newlines.py
jaraco/text/strip-prefix.py
diff --git a/dev-python/jaraco-text/metadata.xml b/dev-python/jaraco-text/metadata.xml
index 53b2aac86a52..7d0942d6335b 100644
--- a/dev-python/jaraco-text/metadata.xml
+++ b/dev-python/jaraco-text/metadata.xml
@@ -12,4 +12,9 @@
<bugs-to>https://github.com/jaraco/jaraco.text/issues</bugs-to>
<changelog>https://github.com/jaraco/jaraco.text/blob/master/CHANGES.rst</changelog>
</upstream>
+ <use>
+ <flag name="cli">
+ Install dependencies needed for CLI tools (Rust warning!)
+ </flag>
+ </use>
</pkgmetadata>