summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-22 04:42:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-22 05:38:36 +0100
commit094b080b97c80fc6e710d88bc4b3fa1cc2a75ed2 (patch)
tree806f367e9d2cc468ed3596a19363486a2cb7ca8d /dev-python/ipyparallel
parentdev-python/starlette: Remove old (diff)
downloadgentoo-094b080b97c80fc6e710d88bc4b3fa1cc2a75ed2.tar.gz
gentoo-094b080b97c80fc6e710d88bc4b3fa1cc2a75ed2.tar.bz2
gentoo-094b080b97c80fc6e710d88bc4b3fa1cc2a75ed2.zip
dev-python/ipyparallel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ipyparallel')
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/files/ipyparallel-8.6.1-pypy310.patch32
-rw-r--r--dev-python/ipyparallel/ipyparallel-8.6.1.ebuild89
3 files changed, 0 insertions, 122 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index a84e0cf0a5f8..309b4cf0c591 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,2 +1 @@
-DIST ipyparallel-8.6.1.tar.gz 6807935 BLAKE2B 23847974e9d5d1d06a64a6b01c845f539848c602b6ba6a22c64d8e0bd35a783ec3a09fc6618ae08490d35e49d497c1db61176f8c70065c4e61ec234a7fd00545 SHA512 e83447f9d52eed87e8513d2ee74d2d6b589a5c04b5bf6dfece6d87565dd9c5e46abd280eb5ab64266b2e759dec1007ab007d0b8232b6239768190bd6900f53ff
DIST ipyparallel-8.7.0.tar.gz 6798726 BLAKE2B 2f948ab19883e9364cab82227ad9918010f144ccf8d9899c54e4a3a9df99bd42faf6001ba837e6c7bfb25738c6ad25f766396b76ba7fa5097d84f385d69dbc68 SHA512 96b9a3c1435dcb609c81856e5fc2763265a14610483e9d6c1a0b1fe5f7d6981d42d8f0d7b0c245cdf1fec10d4a832854dc745ca02ce90623734216dc858bb322
diff --git a/dev-python/ipyparallel/files/ipyparallel-8.6.1-pypy310.patch b/dev-python/ipyparallel/files/ipyparallel-8.6.1-pypy310.patch
deleted file mode 100644
index fae998d51972..000000000000
--- a/dev-python/ipyparallel/files/ipyparallel-8.6.1-pypy310.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 401980b2a79ef15cc3b35fad51163339c8654751 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Mon, 20 Nov 2023 15:45:04 +0100
-Subject: [PATCH] Use pre-3.10 serialization code on PyPy3.10
-
-The new serialization code for Python 3.10+ does not seem to work
-on PyPy3.10 7.3.13, as it causes:
-
- ValueError: no signature found for builtin type <class 'code'>
-
-Switch back to the old code if PyPy is used, at least for the time
-being. With this change, the test suite passes on PyPy3.10.
-
-Fixes #845
----
- ipyparallel/serialize/codeutil.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/ipyparallel/serialize/codeutil.py b/ipyparallel/serialize/codeutil.py
-index 2d3acfa2a..80d107765 100644
---- a/ipyparallel/serialize/codeutil.py
-+++ b/ipyparallel/serialize/codeutil.py
-@@ -27,7 +27,8 @@ def code_ctor(*args):
- }
- # pass every supported arg to the code constructor
- # this should be more forward-compatible
--if sys.version_info >= (3, 10):
-+# (broken on pypy: https://github.com/ipython/ipyparallel/issues/845)
-+if sys.version_info >= (3, 10) and not hasattr(sys, "pypy_version_info"):
- _code_attr_names = tuple(
- _code_attr_map.get(name, name)
- for name, param in inspect.signature(types.CodeType).parameters.items()
diff --git a/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild b/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
deleted file mode 100644
index 96ee69b90056..000000000000
--- a/dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 optfeature pypi
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="
- https://ipyparallel.readthedocs.io/
- https://github.com/ipython/ipyparallel/
- https://pypi.org/project/ipyparallel/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/entrypoints[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-18[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
- >=dev-python/ipython-4[${PYTHON_USEDEP}]
- dev-python/jupyter-client[${PYTHON_USEDEP}]
- dev-python/jupyter-server[${PYTHON_USEDEP}]
- >=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
- dev-python/psutil[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
- dev-python/tqdm[${PYTHON_USEDEP}]
- >=dev-python/tornado-5.1[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/flit-core[${PYTHON_USEDEP}]
- test? (
- dev-python/ipython[test]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-tornado[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
-"
-
-# TODO: package myst_parser
-# distutils_enable_sphinx docs/source
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
- # https://github.com/ipython/ipyparallel/pull/846
- "${FILESDIR}"/${P}-pypy310.patch
-)
-
-src_configure() {
- export IPP_DISABLE_JS=1
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # we don't run a mongo instance for tests
- ipyparallel/tests/test_mongodb.py::TestMongoBackend
- # TODO
- ipyparallel/tests/test_util.py::test_disambiguate_ip
- # Gets upset that a timeout _doesn't_ occur, presumably because
- # we're cranking up too many test timeouts. Oh well.
- # bug #823458#c3
- ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
- # We could patch the timeout for these too but they're going to be inherently
- # fragile anyway based on what they do.
- ipyparallel/tests/test_client.py::TestClient::test_activate
- ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
- ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
- )
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- # move /usr/etc stuff to /etc
- mv "${ED}/usr/etc" "${ED}/etc" || die
-}
-
-pkg_postinst() {
- optfeature "Jupyter Notebook integration" dev-python/notebook
-}