summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-04 07:31:50 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-04 07:34:14 +0200
commit77c03befb18d5eef29c131a58db680a4c12d6c44 (patch)
tree4cabeebfb96093343458b67e83cb69515e72efda /dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild
parentdev-python/Faker: Bump to 25.4.0 (diff)
downloadgentoo-77c03befb18d5eef29c131a58db680a4c12d6c44.tar.gz
gentoo-77c03befb18d5eef29c131a58db680a4c12d6c44.tar.bz2
gentoo-77c03befb18d5eef29c131a58db680a4c12d6c44.zip
dev-python/imageio-ffmpeg: Bump to 0.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild')
-rw-r--r--dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild
new file mode 100644
index 000000000000..ccbb512610be
--- /dev/null
+++ b/dev-python/imageio-ffmpeg/imageio-ffmpeg-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFMPEG wrapper for Python"
+HOMEPAGE="
+ https://github.com/imageio/imageio-ffmpeg/
+ https://pypi.org/project/imageio-ffmpeg/
+"
+SRC_URI="
+ https://github.com/imageio/imageio-ffmpeg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+# ffmpeg is used as an executable during runtime
+RDEPEND="
+ media-video/ffmpeg:*
+"
+
+distutils_enable_tests pytest