summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-04 12:35:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-04 13:57:27 +0200
commit5f68f4eb9dfdd14df2ad2b78ddaa9b3bea74030e (patch)
treee64406b4eac231fe8ad7492c3f1d69bc5c42c063 /dev-python/google-i18n-address
parentdev-python/yarl: Bump to 1.9.8 (diff)
downloadgentoo-5f68f4eb9dfdd14df2ad2b78ddaa9b3bea74030e.tar.gz
gentoo-5f68f4eb9dfdd14df2ad2b78ddaa9b3bea74030e.tar.bz2
gentoo-5f68f4eb9dfdd14df2ad2b78ddaa9b3bea74030e.zip
dev-python/google-i18n-address: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-i18n-address')
-rw-r--r--dev-python/google-i18n-address/Manifest1
-rw-r--r--dev-python/google-i18n-address/google-i18n-address-3.1.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/google-i18n-address/Manifest b/dev-python/google-i18n-address/Manifest
index deeba94c3d0a..32a0f7b9bda3 100644
--- a/dev-python/google-i18n-address/Manifest
+++ b/dev-python/google-i18n-address/Manifest
@@ -1 +1,2 @@
DIST google-i18n-address-3.1.0.gh.tar.gz 726728 BLAKE2B ef41b285aecea0b3e11b08c0815d57a2c3816c59fe01fab64fd75913b0f870e42fbcd0ed76b201c6cd47e4b249c03689b54c648468c3a2cf3d3cb67e2be7ab03 SHA512 b47b5eeaf214a04614ed0976055d25fbce2d298c45db4bfe31b369cd27dc1e097b14d4fae62b5f8dd95be5693d2fda12d0b618029dc1f3ed2784e28b60c43ef9
+DIST google-i18n-address-3.1.1.gh.tar.gz 726391 BLAKE2B 5c77c059a61cd4f8d56bf25d95f9672c3c8185348239a5aafe54b955cc13b84f56d2143db3bb201024d459cd932bc8efe9828c1e77fa1fb2c9b4293efd2d9225 SHA512 7df537ec2f2f06246e1f77dc2eccb87aca30fb9251a3f32acb154b6ab5754f0525d8a06f1adee210f98bd49ace25b1e78075f5ef378ea0c410fcf08c3addd0b1
diff --git a/dev-python/google-i18n-address/google-i18n-address-3.1.1.ebuild b/dev-python/google-i18n-address/google-i18n-address-3.1.1.ebuild
new file mode 100644
index 000000000000..b71b9386ff07
--- /dev/null
+++ b/dev-python/google-i18n-address/google-i18n-address-3.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google's i18n address metadata repository"
+HOMEPAGE="
+ https://github.com/mirumee/google-i18n-address/
+ https://pypi.org/project/google-i18n-address/
+"
+# Using the github release, as it contains the tests (unlike the pypi artifact).
+SRC_URI="
+ https://github.com/mirumee/google-i18n-address/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest