summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-20 09:01:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-20 09:02:17 +0200
commit2ba5994fdd15c48400320714afd522e649b4eb2b (patch)
tree28d13a1bac4698b49a71bd8f665e6d54b4b93bef /dev-python/fuzzywuzzy
parentdev-python/Levenshtein: Remove old (diff)
downloadgentoo-2ba5994fdd15c48400320714afd522e649b4eb2b.tar.gz
gentoo-2ba5994fdd15c48400320714afd522e649b4eb2b.tar.bz2
gentoo-2ba5994fdd15c48400320714afd522e649b4eb2b.zip
dev-python/fuzzywuzzy: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fuzzywuzzy')
-rw-r--r--dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
new file mode 100644
index 000000000000..69ab35341208
--- /dev/null
+++ b/dev-python/fuzzywuzzy/fuzzywuzzy-0.18.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fuzzy string matching in python"
+HOMEPAGE="
+ https://github.com/seatgeek/fuzzywuzzy/
+ https://pypi.org/project/fuzzywuzzy/
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/Levenshtein[${PYTHON_USEDEP}]
+"
+# pycodestyle imported unconditionally in the only test file, sigh
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest