summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-24 17:44:23 +0200
committerSam James <sam@gentoo.org>2022-06-29 17:49:24 +0000
commit39be7497de95deb4cbeba9243ff6cb336bf8e766 (patch)
tree6b62152467efce39b4aab936d7900ef56e55fe89 /dev-python/furo
parentdev-python/sphinx-basic-ng: New package, v0.0.1_alpha11 (diff)
downloadgentoo-39be7497de95deb4cbeba9243ff6cb336bf8e766.tar.gz
gentoo-39be7497de95deb4cbeba9243ff6cb336bf8e766.tar.bz2
gentoo-39be7497de95deb4cbeba9243ff6cb336bf8e766.zip
dev-python/furo: Bump to 2022.6.21
Signed-off-by: Michał Górny <mgorny@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/furo')
-rw-r--r--dev-python/furo/Manifest1
-rw-r--r--dev-python/furo/furo-2022.6.21.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/furo/Manifest b/dev-python/furo/Manifest
index 3bffb6f64e77..3d08c0c1b302 100644
--- a/dev-python/furo/Manifest
+++ b/dev-python/furo/Manifest
@@ -1 +1,2 @@
DIST furo-2021.10.9.tar.gz 69755 BLAKE2B d9dec7f2161491c1b9806fe8e1e98bf6d8f405ae17931e86da6edf44121a0bfbfef4db26f35b53cc929e143926bdbfb4f223aa52fdd65912cd49bd423e574a43 SHA512 4100cb08f6f97ffde2527ec5678e94da759323521bf26ba49dfe4c0851aabc59556872b494a7dec26fbf6e4ac2f2dbc4c7d92f7ef47cae7f9d256af38da91f7e
+DIST furo-2022.6.21-py3-none-any.whl 323874 BLAKE2B aac38e9aaa8d4fc6fdb00a7da9df8781b18229146970a005077075b0049b6493f280377ed735e9dd5425fdce0c43f8cad5b149957018d9a084ad83c5e5fcabeb SHA512 096c9fd0a18c8c4263607a77703412fcc5d7334b08bb6c448e5369b93572f2176f7fbe3fc7eb0b8c72f09d00eeca379debfec2f6565305d2f5e1bd0518af1558
diff --git a/dev-python/furo/furo-2022.6.21.ebuild b/dev-python/furo/furo-2022.6.21.ebuild
new file mode 100644
index 000000000000..67c20b4762c4
--- /dev/null
+++ b/dev-python/furo/furo-2022.6.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# sphinx-theme-builder is completely unusable, as it requires pinning
+# to a very-specific nodejs version number, and ofc loves fetching
+# everything from the Internet
+
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Clean customisable Sphinx documentation theme"
+HOMEPAGE="
+ https://pypi.org/project/furo/
+ https://github.com/pradyunsg/furo/
+"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${PN::1}/${PN}/${P}-py3-none-any.whl
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-basic-ng[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ distutils_wheel_install "${BUILD_DIR}/install" \
+ "${DISTDIR}/${P}-py3-none-any.whl"
+}