summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-09 22:40:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-10 00:16:28 +0200
commit912649024ca6a6b72671fe23088e4cc3d4a56cca (patch)
treef99ba027cda331dba5d0d9e0fe6e4f1dd7c3d104 /dev-python/fsspec
parentdev-python/paste: Bump to 3.4.4 (diff)
downloadgentoo-912649024ca6a6b72671fe23088e4cc3d4a56cca.tar.gz
gentoo-912649024ca6a6b72671fe23088e4cc3d4a56cca.tar.bz2
gentoo-912649024ca6a6b72671fe23088e4cc3d4a56cca.zip
dev-python/fsspec: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fsspec')
-rw-r--r--dev-python/fsspec/Manifest1
-rw-r--r--dev-python/fsspec/fsspec-0.8.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/fsspec/Manifest b/dev-python/fsspec/Manifest
index f348eb423328..69df498f4793 100644
--- a/dev-python/fsspec/Manifest
+++ b/dev-python/fsspec/Manifest
@@ -1,2 +1,3 @@
DIST filesystem_spec-0.7.4.tar.gz 222128 BLAKE2B b111b8194e2c31065a26dcd952aaadf0bc39bf75e94b10f79a387dc1b66838de820bcdcd90af60533dbbd33cfcc275470ccd82b98d0c82154f0633efab355187 SHA512 086e7e7905ff4a55b7027d2b005fd875200bf40469ea4b36effb9805a3416145ba4c709c4a6c8a3ac24a033cbd2104e7ebe401e2610db6c2d8548a63587b343a
DIST filesystem_spec-0.8.0.tar.gz 235922 BLAKE2B 5ca1ce8fe3932ace39f3623217b0918cc7f24c07e86357fd4d3d56630010c37c33e94f0419f5fd6bb86292751ccc93efae305ad3c86c4f94a54b0ae360c9a07d SHA512 55513650f1795657ce274478d4360f2cfc3d2bbd8114df7a458fb3a20277b1594e48b5be38e26154a3af525a169f1e4b3d3c0e387bf3889b78350bacf12cc02b
+DIST filesystem_spec-0.8.1.tar.gz 238298 BLAKE2B a4a5fd16b10de1420a33cdc3ee5a37b3f9c93a9a5ccf179f0b022897bb41c8f22cd517bad7ca8ac3c43190e9fcc92b51142a58349a6b1f51274d27e5da1152f3 SHA512 1447f2fb2fc27b5d3ed18cdf43df3c1da9f0bbc03d2dbd0cd69631cfa629c74d2e35358f8bb560b7d2a7d9bb9b7512e2fcf0f7ad6a2f364334748c0026e4b6a6
diff --git a/dev-python/fsspec/fsspec-0.8.1.ebuild b/dev-python/fsspec/fsspec-0.8.1.ebuild
new file mode 100644
index 000000000000..041adfc0de56
--- /dev/null
+++ b/dev-python/fsspec/fsspec-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+MY_P=filesystem_spec-${PV}
+
+DESCRIPTION="A specification that python filesystems should adhere to"
+HOMEPAGE="https://github.com/intake/filesystem_spec/
+ https://pypi.org/project/fsspec/"
+SRC_URI="
+ https://github.com/intake/filesystem_spec/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ dev-python/versioneer[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_tests pytest
+
+src_test() {
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ # sftp and smb require server started via docker
+ pytest -vv \
+ --ignore fsspec/implementations/tests/test_sftp.py \
+ --ignore fsspec/implementations/tests/test_smb.py ||
+ die "Tests failed with ${EPYTHON}"
+}