summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-27 07:25:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-27 07:32:54 +0200
commitb135f045ae1f88eff5bc29acfc8e6eabe247a24e (patch)
treeafb33cfc137427a3c53159349d3d920a4d53f5df /dev-python/flatbuffers
parentdev-libs/flatbuffers: Bump to 23.5.26 (diff)
downloadgentoo-b135f045ae1f88eff5bc29acfc8e6eabe247a24e.tar.gz
gentoo-b135f045ae1f88eff5bc29acfc8e6eabe247a24e.tar.bz2
gentoo-b135f045ae1f88eff5bc29acfc8e6eabe247a24e.zip
dev-python/flatbuffers: Bump to 23.5.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flatbuffers')
-rw-r--r--dev-python/flatbuffers/Manifest1
-rw-r--r--dev-python/flatbuffers/flatbuffers-23.5.26.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flatbuffers/Manifest b/dev-python/flatbuffers/Manifest
index ad0423302a49..939cb14a6d29 100644
--- a/dev-python/flatbuffers/Manifest
+++ b/dev-python/flatbuffers/Manifest
@@ -1 +1,2 @@
DIST flatbuffers-23.3.3.gh.tar.gz 2197401 BLAKE2B be5e3c8ea81ce4b6f2e2c1b2f22e1172434c435f096fa7dade060578c506cff0310e3e2ef0627e26ce2be44f740652eb9a8e1b63578c18f430f7925820f04e66 SHA512 4066c94f2473c7ea16917d29a613e16f840a329089c88e0bdbdb999aef3442ba00abfd2aa92266fa9c067e399dc88e6f0ccac40dc151378857e665638e78bbf0
+DIST flatbuffers-23.5.26.gh.tar.gz 2257271 BLAKE2B 147425e7c018072f4ae4cdb3e034a4f434362d88d5e27b09375965993c279acfbed36064014c8f4fbe3fb81175ac0aa9b07629675e2c7ad33d59a9c85f2c3bb8 SHA512 cd0a5efad8016e1217d01a181d6b02e546f5693c6412361bfeaee820d5dfe5e2a424cee1963270e851c1a4f936ae8a0032a51c5bb16ee19313e0ecc77dc4ba31
diff --git a/dev-python/flatbuffers/flatbuffers-23.5.26.ebuild b/dev-python/flatbuffers/flatbuffers-23.5.26.ebuild
new file mode 100644
index 000000000000..14742b4d5b04
--- /dev/null
+++ b/dev-python/flatbuffers/flatbuffers-23.5.26.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="RFC 7049 - Concise Binary Object Representation"
+HOMEPAGE="
+ https://github.com/google/flatbuffers/
+ https://pypi.org/project/flatbuffers/
+"
+SRC_URI="
+ https://github.com/google/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P}/python
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cd "${WORKDIR}/${P}/tests" || die
+ # zeroes means without benchmarks
+ "${EPYTHON}" py_test.py 0 0 0 false || die
+ "${EPYTHON}" py_flexbuffers_test.py -v || die
+}