summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 13:41:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 13:59:31 +0100
commit93fa060bea10c6b07a7cde321a68124c27f65ae5 (patch)
tree5d5871e941e3e052a9d59c5c8c85c71e0bbd952e /dev-python/flask-babel
parentdev-python/flask-babel: Stabilize 0.11.2-r2 ALLARCHES (diff)
downloadgentoo-93fa060bea10c6b07a7cde321a68124c27f65ae5.tar.gz
gentoo-93fa060bea10c6b07a7cde321a68124c27f65ae5.tar.bz2
gentoo-93fa060bea10c6b07a7cde321a68124c27f65ae5.zip
dev-python/flask-babel: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-babel')
-rw-r--r--dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild b/dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild
deleted file mode 100644
index a91895d8cc66..000000000000
--- a/dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_6 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Babel"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
-HOMEPAGE="https://pythonhosted.org/Flask-Babel/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
- dev-python/Babel[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- sed -i -e "s/'sphinx.ext.intersphinx'//" \
- -e '/^html_theme =/,/^}/d' docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- nosetests || die "Tests failed under ${EPYTHON}"
-}