summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2016-09-06 13:56:02 +0200
committerTobias Klausmann <klausman@gentoo.org>2016-09-06 13:56:02 +0200
commitb6d547eeeac2ffcf92fb483e15a9c0a07e1290b7 (patch)
tree8197f27403f79e53d6185f97eca71b97ed77cfdf /dev-python/flake8
parentdev-python/pycodestyle: Initial addition to the tree (diff)
downloadgentoo-b6d547eeeac2ffcf92fb483e15a9c0a07e1290b7.tar.gz
gentoo-b6d547eeeac2ffcf92fb483e15a9c0a07e1290b7.tar.bz2
gentoo-b6d547eeeac2ffcf92fb483e15a9c0a07e1290b7.zip
dev-python/{mccabe,flake8}: Version bump and fixes
This version of flake8 now depends on the recently-added pycodestyle. Also, I changed the way the test suite is run to avoid a name collision.
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.0.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 94dd1f377bec..24364278d6c2 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -5,3 +5,4 @@ DIST flake8-2.4.1.tar.gz 50324 SHA256 2e7ebbe59d8c85e626e36d99f0db2f578394313d3f
DIST flake8-2.5.0.tar.gz 82600 SHA256 8216c8c6ee092ae93d51f89bc91045648c88cd9be77d60cf47df7ca26ee4f88c SHA512 6f55ae237fb834fa9376760eddf77553f9edb1b7328175c5f07232b160e4d5ea9d65caa91241f7d1db90845f9c02b8d41129cd453c1b09a4d6870e0e53ba0f8d WHIRLPOOL d08e5c2d2c488e558e02a272c1753defa2a200d37b2b113f1f1523dc06f6ee5dc7f37c60f598eff91c4aeb47a76bd0dd60c0fdd7d2a6b7fa0a7bbec2b60a88d2
DIST flake8-2.5.1.tar.gz 83692 SHA256 448aed48b0671fe6062f47b98c3081f3a4b36fbe99ddb8ac2a3be6e6cb135603 SHA512 030d2464717f62e3c5501631e7bc4482321086ca3e7f7dfe845dab66aaf38be94565c1e147792ba7e7d2850fd5290e61a24fe1006daf18c3be2ff81348c5731c WHIRLPOOL 63a6915eeb32be4aa51f3b69c5c6918c3a2953a4dff203515d20a10e58dc12cf7732a5e715b279c17d2a0e4b77f6879dc9f489395ddbcb6d0c340a21be39f9e4
DIST flake8-2.5.4.tar.gz 81663 SHA256 cc1e58179f6cf10524c7bfdd378f5536d0a61497688517791639a5ecc867492f SHA512 31cbec556fc41361ac464d2547275e319ab663c907a4a8644113a2288a9f349bcfbec85197b6dfa13a7db9e82419f01e0f2abc84a347e133c144ea137e0daa28 WHIRLPOOL 2547b78092b1a85edd2a0d03d9e0bc31e7d3b7cb3958cf5dea9947377851a69d5c37f64c0d65a5d7e88ab9573597729adbe07ae758b0510e455b26bf62292f47
+DIST flake8-3.0.4.tar.gz 1382588 SHA256 b4c210c998f07d6ff24325dd91fbc011f2c37bcd6bf576b188de01d8656e970d SHA512 845b38824112edfc8244f6ec795b5659f99b4e8171af5e6c737f345e5a429f7b26f57e24ccc42fa2d8117b7ceff4dd100fe840064260fa17f203804e4b83ab06 WHIRLPOOL 79300674a1a326d95e80208cee664b0ddcd518653cac2aac381a3a32c1bcc40b4ddb00f95b064e119bc7f40098240e77b16898db688b87a2571ad523eac72a44
diff --git a/dev-python/flake8/flake8-3.0.4.ebuild b/dev-python/flake8/flake8-3.0.4.ebuild
new file mode 100644
index 000000000000..3d9a910153d5
--- /dev/null
+++ b/dev-python/flake8/flake8-3.0.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://bitbucket.org/tarek/flake8 https://pypi.python.org/pypi/flake8"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+IUSE="test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+LICENSE="MIT"
+SLOT="0"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-0.8.1[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-1.3[${PYTHON_USEDEP}]
+ !=dev-python/pyflakes-1.2.0[${PYTHON_USEDEP}]
+ !=dev-python/pyflakes-1.2.1[${PYTHON_USEDEP}]
+ !=dev-python/pyflakes-1.2.2[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
+ <=dev-python/pycodestyle-2.1.0[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/mccabe-0.2.1[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.5[${PYTHON_USEDEP}]
+ )"
+PDEPEND="
+ >=dev-python/mccabe-0.5.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.6[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.0.0[${PYTHON_USEDEP}]
+ <=dev-python/pycodestyle-2.1.0[${PYTHON_USEDEP}]
+ "
+
+python_prepare_all() {
+ # Gentoo has flake8 support restored in >=pep8-1.6.2-r1.
+ sed -e 's:, != 1.6.2::' -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # The test suite assumes the presence of a tox.ini file in ${S},
+ # yet the distributed tarballs do not include that file.
+ touch "${S}/tox.ini" || die "Could not create tox.ini"
+
+ # using "test" instead of "ptr" results in name collisions
+ esetup.py ptr
+}