summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-02 13:02:56 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-02 14:24:30 +0100
commit85912fa36930eb6fc03a0edc6c2981531fa4180a (patch)
treef600f1c302ea854cc52259cdcdd3a8625f625a8e /dev-python/findimports
parentdev-python/blake3: Bump to 0.4.0 (diff)
downloadgentoo-85912fa36930eb6fc03a0edc6c2981531fa4180a.tar.gz
gentoo-85912fa36930eb6fc03a0edc6c2981531fa4180a.tar.bz2
gentoo-85912fa36930eb6fc03a0edc6c2981531fa4180a.zip
dev-python/findimports: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/findimports')
-rw-r--r--dev-python/findimports/Manifest1
-rw-r--r--dev-python/findimports/findimports-2.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/findimports/Manifest b/dev-python/findimports/Manifest
index c1262f34a16c..7a82b2e4702c 100644
--- a/dev-python/findimports/Manifest
+++ b/dev-python/findimports/Manifest
@@ -1 +1,2 @@
DIST findimports-2.3.0.gh.tar.gz 36667 BLAKE2B 3f0981a9819940d2fc5a1b1147b06552b5d98d90594ce94e3c02f1d69904dc65087603ae3375e5321386ae7d00eb82d4ed60d865829f56f6b4e8dbd7540c505c SHA512 f0023995bd5c79e33722a0af7f246e9a5a143fb7f5294b7e1e97b3eb82331f69f605d41551c09af53424d6bf8e41bd5817cc9e206a30d0fc0f1cc0131944e37c
+DIST findimports-2.4.0.gh.tar.gz 26597 BLAKE2B 8dc176a551a07f38996ddbcf0df865ad7c7c1c7f86036be0939578a932155f30bdff17d2880063edd49ae1d169ebfb5bbade771a626859ad8306d54df743ee79 SHA512 90dfc39a5f73ea86a9d5c3ebec0f220f2f428f5768edc9688c47079f555b44abb80b4945b38550032289a3bff659f3857019a50882b1b2f2e83570f3e36530be
diff --git a/dev-python/findimports/findimports-2.4.0.ebuild b/dev-python/findimports/findimports-2.4.0.ebuild
new file mode 100644
index 000000000000..a41a1ff447f3
--- /dev/null
+++ b/dev-python/findimports/findimports-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module import analysis tool"
+HOMEPAGE="
+ https://github.com/mgedmin/findimports/
+ https://pypi.org/project/findimports/
+"
+SRC_URI="
+ https://github.com/mgedmin/findimports/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" testsuite.py -v || die
+}