summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-29 02:27:20 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-29 02:27:20 -0400
commita794e587459d8de9ae3b30a44d1e2695c10d548d (patch)
treeab2ad2d3e28bb9d921b53018c2c0fc1030ba2137 /dev-python/execnet
parentdev-python/cryptography: version bump to 2.1.2 (diff)
downloadgentoo-a794e587459d8de9ae3b30a44d1e2695c10d548d.tar.gz
gentoo-a794e587459d8de9ae3b30a44d1e2695c10d548d.tar.bz2
gentoo-a794e587459d8de9ae3b30a44d1e2695c10d548d.zip
dev-python/execnet: version bump to 1.5.0
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest1
-rw-r--r--dev-python/execnet/execnet-1.5.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index aa51fef73b9d..f4313d1912bd 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1 +1,2 @@
DIST execnet-1.4.1.tar.gz 171041 SHA256 f66dd4a7519725a1b7e14ad9ae7d3df8e09b2da88062386e08e941cafc0ef3e6 SHA512 e8c0c32e873f8585ff4d4da3b9cbd40046479370f5653f67a98c9029d4535a619731d1b825332fe4af4dc5ebc9ab11ee879ef45df07f08943b1e1685f2255790 WHIRLPOOL 487c31617b78e4eeed9dc75ae8f01ade33aad35f7547677ec007b688071dd56e69c4f4b92cf9355dee7cea97bf6eac09f508099f104cf52d6c9fe3860e4fd3c9
+DIST execnet-1.5.0.tar.gz 168497 SHA256 a7a84d5fa07a089186a329528f127c9d73b9de57f1a1131b82bb5320ee651f6a SHA512 ca2b571fafdf8f68b3cc7a04ee326e3255828d4cde28ead65d0cef325569c3a6dee09359e525152248038de65326ffc6b75c8362f53aa5c0b3f736eb596cb2d9 WHIRLPOOL 2cd562109412e3133824705fcb4d2a7c083c6a3aac79456b104eea4cfb7f33346e90c82aed39afbfb8cb9990814ef6b088aeacf471b542d46441d2287ef7387b
diff --git a/dev-python/execnet/execnet-1.5.0.ebuild b/dev-python/execnet/execnet-1.5.0.ebuild
new file mode 100644
index 000000000000..3a8a1c3f8986
--- /dev/null
+++ b/dev-python/execnet/execnet-1.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Rapid multi-Python deployment"
+HOMEPAGE="http://codespeak.net/execnet/ https://pypi.python.org/pypi/execnet/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+#PATCHES=( "${FILESDIR}"/1.2.0-tests.patch )
+RESTRICT="test"
+
+python_prepare_all() {
+ # Remove doctest that access an i'net site
+ rm doc/example/test_info.rst || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # https://bitbucket.org/hpk42/execnet/issue/10
+ unset PYTHONDONTWRITEBYTECODE
+ py.test testing || die "Tests fail with ${EPYTHON}"
+
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}