summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:29:42 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:29:42 +0100
commit63ca91b1428b202c1b5060cb8df79995808a5644 (patch)
treeb5984c0f88b239bf7660f2b92cdf67c633d90bb7 /dev-python/execnet
parentdev-python/boto: Remove old (diff)
downloadgentoo-63ca91b1428b202c1b5060cb8df79995808a5644.tar.gz
gentoo-63ca91b1428b202c1b5060cb8df79995808a5644.tar.bz2
gentoo-63ca91b1428b202c1b5060cb8df79995808a5644.zip
dev-python/execnet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/Manifest1
-rw-r--r--dev-python/execnet/execnet-1.7.1-r1.ebuild45
-rw-r--r--dev-python/execnet/files/execnet-1.7.1-tests.patch224
3 files changed, 0 insertions, 270 deletions
diff --git a/dev-python/execnet/Manifest b/dev-python/execnet/Manifest
index 0583cb20fd21..248028e983c6 100644
--- a/dev-python/execnet/Manifest
+++ b/dev-python/execnet/Manifest
@@ -1,2 +1 @@
-DIST execnet-1.7.1.tar.gz 174157 BLAKE2B 0c2f7b8918bdd5a3cd1fdc49607e571874e20bd26a4806a6ec1a11359b912ed09244afb781670ff24fbee752516d59ab2bba7f662bbcddb802e7e6efd2c544ef SHA512 375748c03f8d955bd8fca90d5c6308073c31a978fd7a604257512e0a710f899dec5db8a91d5bb5f16de9b0656e1742da9ab513827a1a065a5125bafcf1e63a70
DIST execnet-1.8.0.tar.gz 173765 BLAKE2B c6334a98b0e9dc7eb5e83fef05b795371edd0f85a6cbad9dc80d14f2e944204812c58419afebe5e70514f41d5ee7507b6a224a94e8cee2544607bc28ef5b175d SHA512 a0ca76002270daa5cbfa00563a51a3412008f893f755a1eb84f53e228dd61a82bdc94fe6152e30d471b4caff3059c662bb9de82100ec2c96df4d014836452698
diff --git a/dev-python/execnet/execnet-1.7.1-r1.ebuild b/dev-python/execnet/execnet-1.7.1-r1.ebuild
deleted file mode 100644
index e7ac3f87bd76..000000000000
--- a/dev-python/execnet/execnet-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="https://codespeak.net/execnet/
- https://pypi.org/project/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-macos"
-
-RDEPEND=">=dev-python/apipkg-1.4[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/execnet-1.7.1-tests.patch"
-)
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Remove doctest that access an i'net site
- rm doc/example/test_info.rst || die
-
- sed -i -r 's:(,[[:space:]]*|)"eventlet":: ; s:(,[[:space:]]*|)"gevent"(,|)::' \
- testing/conftest.py || die
-
- # get rid of setuptools_scm dep
- sed -i -r "s:use_scm_version=.+,:version='${PV}',: ; s:\"setuptools_scm\"::" \
- setup.py || die
-
- printf -- '__version__ = "%s"\nversion = "%s"\n' "${PV}" "${PV}" > \
- execnet/_version.py || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/execnet/files/execnet-1.7.1-tests.patch b/dev-python/execnet/files/execnet-1.7.1-tests.patch
deleted file mode 100644
index 5144201d2a1f..000000000000
--- a/dev-python/execnet/files/execnet-1.7.1-tests.patch
+++ /dev/null
@@ -1,224 +0,0 @@
-diff --git a/testing/test_channel.py b/testing/test_channel.py
-index 017abb0..0983bae 100644
---- a/testing/test_channel.py
-+++ b/testing/test_channel.py
-@@ -3,6 +3,7 @@
- mostly functional tests of gateways.
- """
- import time
-+import platform
-
- import py
- import pytest
-@@ -362,6 +363,7 @@ class TestChannelFile:
- s = f.read(5)
- assert s == ""
-
-+ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
- def test_channel_file_readline_remote(self, gw):
- channel = gw.remote_exec(
- """
-@@ -382,7 +384,7 @@ class TestChannelFile:
-
-
- class TestStringCoerce:
-- @pytest.mark.skipif('sys.version>="3.0"')
-+ @pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_2to3(self, makegateway):
- python = _find_version("3")
- gw = makegateway("popen//python=%s" % python)
-@@ -410,7 +412,7 @@ class TestStringCoerce:
- assert isinstance(res, str)
- gw.exit()
-
-- @pytest.mark.skipif('sys.version<"3.0"')
-+ @pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_3to2(self, makegateway):
- python = _find_version("2")
- gw = makegateway("popen//python=%s" % python)
-diff --git a/testing/test_gateway.py b/testing/test_gateway.py
-index fc1cf6a..b06a18d 100644
---- a/testing/test_gateway.py
-+++ b/testing/test_gateway.py
-@@ -5,6 +5,7 @@ mostly functional tests of gateways.
- import os
- import socket
- import subprocess
-+import platform
- import sys
- from textwrap import dedent
-
-@@ -153,6 +154,7 @@ class TestBasicGateway:
-
- assert result is True
-
-+ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
- def test_remote_exec_module_with_traceback(self, gw, tmpdir, monkeypatch):
- remotetest = tmpdir.join("remotetest.py")
- remotetest.write(
-@@ -233,6 +235,7 @@ class TestBasicGateway:
- assert result == 42
-
- @needs_osdup
-+ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
- def test_confusion_from_os_write_stdout(self, gw):
- channel = gw.remote_exec(
- """
-@@ -250,6 +253,7 @@ class TestBasicGateway:
- assert res == 42
-
- @needs_osdup
-+ @pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
- def test_confusion_from_os_write_stderr(self, gw):
- channel = gw.remote_exec(
- """
-@@ -355,6 +359,7 @@ class TestPopenGateway:
- )
- py.test.raises(channel.RemoteError, channel.receive)
-
-+ @pytest.mark.skip(reason="fails if bytecode writing is on")
- def test_dont_write_bytecode(self, makegateway):
- check_sys_dont_write_bytecode = """
- import sys
-@@ -498,7 +503,7 @@ class TestTracing:
-
-
- class TestStringCoerce:
-- @py.test.mark.skipif('sys.version>="3.0"')
-+ @pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_2to3(self, makegateway):
- python = _find_version("3")
- gw = makegateway("popen//python=%s" % python)
-@@ -515,7 +520,7 @@ class TestStringCoerce:
- assert isinstance(res, str)
- gw.exit()
-
-- @py.test.mark.skipif('sys.version<"3.0"')
-+ @pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_3to2(self, makegateway):
- python = _find_version("2")
- gw = makegateway("popen//python=%s" % python)
-diff --git a/testing/test_rsync.py b/testing/test_rsync.py
-index 995f229..a3f69a3 100644
---- a/testing/test_rsync.py
-+++ b/testing/test_rsync.py
-@@ -230,6 +230,7 @@ class TestRSync:
- assert len(dest.listdir()) == 1
- assert len(source.listdir()) == 1
-
-+ @pytest.mark.skip(reason="tries to run other python impls")
- @py.test.mark.skipif("sys.version_info >= (3,)")
- def test_2_to_3_bridge_can_send_binary_files(self, tmpdir, makegateway):
- python = _find_version("3")
-diff --git a/testing/test_serializer.py b/testing/test_serializer.py
-index 892e474..2f7f2f7 100644
---- a/testing/test_serializer.py
-+++ b/testing/test_serializer.py
-@@ -146,6 +146,7 @@ simple_tests = [
- ]
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- @py.test.mark.parametrize(["tp_name", "repr"], simple_tests)
- def test_simple(tp_name, repr, dump, load):
- p = dump(repr)
-@@ -154,6 +155,7 @@ def test_simple(tp_name, repr, dump, load):
- assert v == repr
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_set(py2, py3, dump):
- p = dump("set((1, 2, 3))")
- tp, v = py2.load(p)
-@@ -176,6 +178,7 @@ def test_set(py2, py3, dump):
- assert v == "set()"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_frozenset(py2, py3, dump):
- p = dump("frozenset((1, 2, 3))")
- tp, v = py2.load(p)
-@@ -193,6 +196,7 @@ def test_frozenset(py2, py3, dump):
- assert v == "frozenset()"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_long(py2, py3):
- really_big = "9223372036854775807324234"
- p = py2.dump(really_big)
-@@ -211,6 +215,7 @@ def test_long(py2, py3):
- assert v == really_big + "L"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_small_long(py2, py3):
- p = py2.dump("123L")
- tp, s = py2.load(p)
-@@ -219,6 +224,7 @@ def test_small_long(py2, py3):
- assert s == "123"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_bytes(py2, py3):
- p = py3.dump("b'hi'")
- tp, v = py2.load(p)
-@@ -229,6 +235,7 @@ def test_bytes(py2, py3):
- assert v == "b'hi'"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_str(py2, py3):
- p = py2.dump("'xyz'")
- tp, s = py2.load(p)
-@@ -242,6 +249,7 @@ def test_str(py2, py3):
- assert tp == "bytes"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_unicode(py2, py3):
- p = py2.dump("u'hi'")
- tp, s = py2.load(p)
-@@ -260,6 +268,7 @@ def test_unicode(py2, py3):
- assert s == "u'hi'"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_bool(py2, py3):
- p = py2.dump("True")
- tp, s = py2.load(p)
-@@ -273,12 +282,14 @@ def test_bool(py2, py3):
- assert s == "False"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_none(dump, load):
- p = dump("None")
- tp, s = load(p)
- assert s == "None"
-
-
-+@pytest.mark.skip(reason="trying to run stuff under different impls")
- def test_tuple_nested_with_empty_in_between(py2):
- p = py2.dump("(1, (), 3)")
- tp, s = py2.load(p)
-diff --git a/testing/test_threadpool.py b/testing/test_threadpool.py
-index d469436..a473e4a 100644
---- a/testing/test_threadpool.py
-+++ b/testing/test_threadpool.py
-@@ -3,6 +3,7 @@ from __future__ import with_statement
-
- import os
- import sys
-+import platform
-
- import py
- import pytest
-@@ -29,7 +30,7 @@ def test_simple(pool):
- reply = pool.spawn(lambda: 42)
- assert reply.get() == 42
-
--
-+@pytest.mark.skipif('pypy' in platform.python_implementation().lower(), reason="broken on pypy")
- def test_some(pool, execmodel):
- q = execmodel.queue.Queue()
- num = 4