summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-24 08:30:49 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-24 08:41:09 +0100
commita46625fdb74fa1b2ce628623e4299c02fc6744b1 (patch)
treee9e6bedd837d543397514a7fa0fb9e1e58dc1097 /dev-python/exceptiongroup
parentdev-python/Nuitka: Bump to 1.3.2 (diff)
downloadgentoo-a46625fdb74fa1b2ce628623e4299c02fc6744b1.tar.gz
gentoo-a46625fdb74fa1b2ce628623e4299c02fc6744b1.tar.bz2
gentoo-a46625fdb74fa1b2ce628623e4299c02fc6744b1.zip
dev-python/exceptiongroup: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest1
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 298a89cc3c09..6af486a94872 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1 +1,2 @@
DIST exceptiongroup-1.0.4.gh.tar.gz 22529 BLAKE2B bdf58d36ea59cc7bed17947e4671c92058e7036b20c91df434625d8627db41d646dd0b90ea397c25674753e3ba09654f5978c22220e13007d0af8b1fe659540d SHA512 18f207cb028f1b9ab1073c2859b4aeff357706c3d4c9f05fbe8739f3e19852dd91da5be9c9e18b14b16bd494fc8bf1bd26d058e925084da8c00eac5ad057e2be
+DIST exceptiongroup-1.1.0.gh.tar.gz 22724 BLAKE2B 2de748494fe1356353b7f70d3afc7be7ecb8df4166f57461459c7f463bc5c22340c9073b0b0e032a52680560e37e4004c754fb4ddcc1a5a70f8dd0e973b1d8a9 SHA512 588b4ec3cae01a64140aac191cbdf8d0631eb614d430bbdbd02d17d8ff43aad9d233c3545694c6fffb622a2b3c38a289e20f1b8db6bf0e9b8819d668e38a87e3
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.1.0.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.1.0.ebuild
new file mode 100644
index 000000000000..999c9c16bc4c
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}