summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:15:05 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 14:15:05 -0600
commit38f8cf34ba10e96e8d7a685fc667b72b4543a76f (patch)
tree6a92caa648eef4187ab57cbadb4043954647054d /dev-python/django-filter
parentdev-python/django-debug-toolbar: 2.1 bump (diff)
downloadgentoo-38f8cf34ba10e96e8d7a685fc667b72b4543a76f.tar.gz
gentoo-38f8cf34ba10e96e8d7a685fc667b72b4543a76f.tar.bz2
gentoo-38f8cf34ba10e96e8d7a685fc667b72b4543a76f.zip
dev-python/django-filter: 2.2.0 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/django-filter')
-rw-r--r--dev-python/django-filter/Manifest1
-rw-r--r--dev-python/django-filter/django-filter-2.2.0.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/django-filter/Manifest b/dev-python/django-filter/Manifest
index 731d3c06531a..5691ef83233d 100644
--- a/dev-python/django-filter/Manifest
+++ b/dev-python/django-filter/Manifest
@@ -1 +1,2 @@
DIST django-filter-2.1.0.tar.gz 142256 BLAKE2B 0763c3032cdd857be30050caa27af6bd938030c37cc52f30c98ab751c81dc8b2ce0c974ed19ae8c859347fbec2139b27a08657e99c83bc8e79b8883196050897 SHA512 e917ec0fb1cdb8f19e6a7e50989d2df3697baa0bb50eaa62f5916cc0fe000e1e3594672a312114ab761d49b9f83bf7f5c1f4a35f4014c113ac9387a9bf086e10
+DIST django-filter-2.2.0.tar.gz 142804 BLAKE2B f2385fe3afa78349395bd3334461ad2acc760a2007d4b69618993e176899c77e8585d90bb68578e561a16459cdf35a480adf0a0e6235d6500e5f2c2a7c602445 SHA512 16a4336d1558cabfe497dd9736a2f652c9f9d141a72c856cf13f3ca56db4da85b5926b05c772aef5fa43a75e085025244b8deaf7facbc5bfa68907bd99f4f95d
diff --git a/dev-python/django-filter/django-filter-2.2.0.ebuild b/dev-python/django-filter/django-filter-2.2.0.ebuild
new file mode 100644
index 000000000000..bec056b673e0
--- /dev/null
+++ b/dev-python/django-filter/django-filter-2.2.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 )
+inherit distutils-r1
+
+DESCRIPTION="Django app allowing declarative dynamic QuerySet filtering from URL parameters"
+HOMEPAGE="https://github.com/carltongibson/django-filter"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+dev-python/setuptools[${PYTHON_USEDEP}]"