summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-17 05:31:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-17 05:33:27 +0200
commite22b017059ca732feeed5c265f5175614eb5a50d (patch)
tree5f7749cfb4f882cc29dc2bbb7dce8f8deb9eca05 /dev-python/django-debug-toolbar
parentdev-python/starlette: Bump to 0.27.0 (diff)
downloadgentoo-e22b017059ca732feeed5c265f5175614eb5a50d.tar.gz
gentoo-e22b017059ca732feeed5c265f5175614eb5a50d.tar.bz2
gentoo-e22b017059ca732feeed5c265f5175614eb5a50d.zip
dev-python/django-debug-toolbar: Bump to 4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django-debug-toolbar')
-rw-r--r--dev-python/django-debug-toolbar/Manifest1
-rw-r--r--dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/django-debug-toolbar/Manifest b/dev-python/django-debug-toolbar/Manifest
index a696a2a74824..c2f27e55cea3 100644
--- a/dev-python/django-debug-toolbar/Manifest
+++ b/dev-python/django-debug-toolbar/Manifest
@@ -1,2 +1,3 @@
DIST django-debug-toolbar-3.8.1.gh.tar.gz 269449 BLAKE2B e93da38cdb6aa160dab65816858b1f7ca532ad22617e1859669fc508472086a93807aa874fde92ef95e6e33268a2f14de19d1498a15ca92ec89a9f8b3bf2a323 SHA512 4fa7b3fa3f9767cf1edba26c9de625675bcb1bafcb6d88d7ab95c331da6865f5c3cdb25848a6d2f4befdf9b2e65db4123b496f06a1b2e39eb3ee71f0c3384d26
DIST django-debug-toolbar-4.0.0.gh.tar.gz 265429 BLAKE2B ee444246fc71bef989451bbb53e35d2be072ec9b219dfc9a9018fe736a9b750d271adc5af040374cfcb6a8e4ed26260640a952308576997e2bf42da3aec9fec4 SHA512 6a6d586a9a3c87811193c19a5fd5cb425700573a1ece71ed13d76caba208da14a1beb32e2dbc69e8ea7f09d52f42bf3b71f9608f91cc51ec41ab92558bf7e2c9
+DIST django-debug-toolbar-4.1.gh.tar.gz 267550 BLAKE2B 80ebec1ee6f09d44089e119107a3696b8db82263976b4d191aaeea89658b0fbfb7ca1e2975aa73ad5c9240ac3010816710b5f7386165b1d7bdf335f8ef82b896 SHA512 8e9cc1ffcd8be7e345fff78e60cde8c4b44ef751dbf6a6bc061d452ccb60c68eda9f7e7a17efc32be3a62601921dff87f52ba2fe0e47a17fb820bf025cac0035
diff --git a/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild b/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild
new file mode 100644
index 000000000000..2fbcb24e5a3a
--- /dev/null
+++ b/dev-python/django-debug-toolbar/django-debug-toolbar-4.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A configurable set of panels that display various debug information"
+HOMEPAGE="
+ https://github.com/jazzband/django-debug-toolbar/
+ https://pypi.org/project/django-debug-toolbar/
+"
+# no tests in sdist, as of 4.0.0
+SRC_URI="
+ https://github.com/jazzband/django-debug-toolbar/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" -m django test -v 2 --settings tests.settings \
+ || die "Tests failed with ${EPYTHON}"
+}