summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-01 21:55:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-01 22:41:51 +0300
commitcdd930d1506e21b70c3d5c988fb0b417a6d89b28 (patch)
tree4ae0271fa4a50de9b28b5f31059e7fd4a5c80ffb /dev-python/django-configurations
parentdev-python/python-glanceclient: add 4.1.0 (diff)
downloadgentoo-cdd930d1506e21b70c3d5c988fb0b417a6d89b28.tar.gz
gentoo-cdd930d1506e21b70c3d5c988fb0b417a6d89b28.tar.bz2
gentoo-cdd930d1506e21b70c3d5c988fb0b417a6d89b28.zip
dev-python/django-configurations: add 2.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/django-configurations')
-rw-r--r--dev-python/django-configurations/Manifest1
-rw-r--r--dev-python/django-configurations/django-configurations-2.4.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/django-configurations/Manifest b/dev-python/django-configurations/Manifest
index ab7809eb6eca..1fee3c094acf 100644
--- a/dev-python/django-configurations/Manifest
+++ b/dev-python/django-configurations/Manifest
@@ -1 +1,2 @@
DIST django-configurations-2.3.2.gh.tar.gz 38475 BLAKE2B 2b3c583e665a08a46bc0ca0c52ae4326fbdfb794d102deecbd13f953e8b6f3fd39b3b747c591fc9717c6a0792258cdb9041de53e71db2034de1a31ddf5bfc0ea SHA512 4cb5a7b284a0025ba93b32e158fb65b57e66230938181b921a1b1264848113b697eb45ac6ad2fc4f26f3bc29ea5f77acbfd5307b20ef2d385e29c2c1746295b3
+DIST django-configurations-2.4.gh.tar.gz 38563 BLAKE2B a454cc492354c1b969a1b0389ccb21088e99af17b5056ae514b36b5c2fd7391368437093d1a075814dfb8e15ec8ce3ec3c5269d5c867b4a03a5269a533826a31 SHA512 de9793c5fce869ef77e4396dd5ea45fc57728d702383885599d3a08b16e37e0e425258aacd671ac78592df813c8fa3a08b33ad9410843f7d7976589da33592ca
diff --git a/dev-python/django-configurations/django-configurations-2.4.ebuild b/dev-python/django-configurations/django-configurations-2.4.ebuild
new file mode 100644
index 000000000000..cd1f8512e9ff
--- /dev/null
+++ b/dev-python/django-configurations/django-configurations-2.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A helper for organizing Django settings"
+HOMEPAGE="
+ https://pypi.org/project/django-configurations/
+ https://github.com/jazzband/django-configurations/
+ https://django-configurations.readthedocs.io/
+"
+SRC_URI="
+ https://github.com/jazzband/django-configurations/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/django-cache-url[${PYTHON_USEDEP}]
+ dev-python/dj-database-url[${PYTHON_USEDEP}]
+ dev-python/dj-email-url[${PYTHON_USEDEP}]
+ dev-python/dj-search-url[${PYTHON_USEDEP}]
+ )
+"
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ local -x DJANGO_SETTINGS_MODULE=tests.settings.main
+ local -x DJANGO_CONFIGURATION=Test
+ PYTHONPATH=. django-cadmin test -v2 || die "Tests failed with ${EPYTHON}"
+}