summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-12-13 20:41:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-12-13 21:53:26 +0200
commit70a0dd78e4d4369d2d04c504678f1d1fcff7e70d (patch)
tree593204f3fea190e771f493f7fa4c6a02e4820944 /dev-python/discogs-client
parentdev-python/ipdb: add github upstream metadata (diff)
downloadgentoo-70a0dd78e4d4369d2d04c504678f1d1fcff7e70d.tar.gz
gentoo-70a0dd78e4d4369d2d04c504678f1d1fcff7e70d.tar.bz2
gentoo-70a0dd78e4d4369d2d04c504678f1d1fcff7e70d.zip
dev-python/discogs-client: add 2.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/discogs-client')
-rw-r--r--dev-python/discogs-client/Manifest1
-rw-r--r--dev-python/discogs-client/discogs-client-2.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
index eb50cfca2ea4..3377ae453cb4 100644
--- a/dev-python/discogs-client/Manifest
+++ b/dev-python/discogs-client/Manifest
@@ -1 +1,2 @@
DIST python3-discogs-client-2.5.tar.gz 36003 BLAKE2B e2350cc2eed986566be79ce3b529885113739da6b42f77dd405456e0552a68d51d1945f3ba569e05b9afc6304233a8b5ebe7c9f4f8105d62d9d159da7a0ff3ec SHA512 d6c90d6f0b472cdeda2a0d019386e3ab609ff46a82c3eefcd9b69162e1f94b34d58916dfb2364afb8cd9def0bf11e60cbed2e2c2dbb03206ea9a0faf141aa4ec
+DIST python3-discogs-client-2.6.tar.gz 36426 BLAKE2B 1d2ae337beb0aaf9cc7310b13909a0a9172c79813ccc0a581af5478cbf45b28d2654b963df2881ad858fcabd5e85594c9a41458283e9e2c9c90ed4d6ad57853c SHA512 2b2ed4a56337b184266832682f7fa4d8726cc414b89446b2a6e96131d82c01c60bd78ac3336bdf94a3077ea25a313fbd532ba574cad64ddc9ab0229d0d7e44b1
diff --git a/dev-python/discogs-client/discogs-client-2.6.ebuild b/dev-python/discogs-client/discogs-client-2.6.ebuild
new file mode 100644
index 000000000000..c8b04833cbf4
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python3-${P}"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest