summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-01 09:03:18 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-01 09:30:23 +0200
commit3cd03612db837f2cef4c695a93f28fe8b7be0f08 (patch)
tree529263665a8b15362c0a08429880f98f80ce799e /dev-python/dirty-equals
parentdev-util/systemtap: Drop python3_7 (diff)
downloadgentoo-3cd03612db837f2cef4c695a93f28fe8b7be0f08.tar.gz
gentoo-3cd03612db837f2cef4c695a93f28fe8b7be0f08.tar.bz2
gentoo-3cd03612db837f2cef4c695a93f28fe8b7be0f08.zip
dev-python/dirty-equals: Bump to 0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dirty-equals')
-rw-r--r--dev-python/dirty-equals/Manifest1
-rw-r--r--dev-python/dirty-equals/dirty-equals-0.4.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/dirty-equals/Manifest b/dev-python/dirty-equals/Manifest
index 1060596d4408..6f04bc80fdc4 100644
--- a/dev-python/dirty-equals/Manifest
+++ b/dev-python/dirty-equals/Manifest
@@ -1 +1,2 @@
DIST dirty-equals-0.3.gh.tar.gz 41665 BLAKE2B af46fb9b7f0e0eb6aba09e682db73b8eef4ab9d73523cf81fb510c093cbaaa18f87c9666094aa05031eda1c32374113bc59b404ab987472821aa21ef135c038d SHA512 b6bf9a241abdbf9f74dec6efa48a23d3a665910d964947b4583127930e940001600b410d524ab1ac48c75a030f1a37528a8dbce30e982f09f913b2b3afca77f1
+DIST dirty-equals-0.4.gh.tar.gz 41864 BLAKE2B 0b916d37b323e9f587a977b46415432bc11367a6d0c95ac49e47fe604b3ee16c26eaecbbe74464076834c6186f5f0eecc049b211699a3f515ef7fdadc492537a SHA512 f98fa8c9850f26efc44dc2c5cc0ea6d687c07b49980c3eeaa71eaae78930e418c03bb35cb88aab065905443fa354b9b05d44a588458ed37d140d376b943c9da9
diff --git a/dev-python/dirty-equals/dirty-equals-0.4.ebuild b/dev-python/dirty-equals/dirty-equals-0.4.ebuild
new file mode 100644
index 000000000000..2f8a22f1ddcc
--- /dev/null
+++ b/dev-python/dirty-equals/dirty-equals-0.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Doing dirty (but extremely useful) things with equals"
+HOMEPAGE="
+ https://dirty-equals.helpmanual.io/
+ https://github.com/samuelcolvin/dirty-equals/
+ https://pypi.org/project/dirty-equals/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/dirty-equals/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/pytz-2021.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ epytest
+}