summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 09:29:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 09:58:04 +0200
commitbad9b5ad1528bec0617c59c11ffa8708636ed27e (patch)
treeafc76b6e735638d99a15a7ef9adecc4339e3ecf8 /dev-python/cliff
parentdev-python/autopage: New dep of dev-python/cliff (diff)
downloadgentoo-bad9b5ad1528bec0617c59c11ffa8708636ed27e.tar.gz
gentoo-bad9b5ad1528bec0617c59c11ffa8708636ed27e.tar.bz2
gentoo-bad9b5ad1528bec0617c59c11ffa8708636ed27e.zip
dev-python/cliff: Bump to 3.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cliff')
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-3.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index e781489dcdb6..10a5a849da0c 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-3.8.0.tar.gz 81862 BLAKE2B 3a8219f822fdf14e1de56204b0f536a92d27be5a99fb628f3aed5b569a1e703d4711bdded28fa42c0692316454847ba3338baac8efae873540652e46d155227a SHA512 002e3ddfb254c5369582cc28572856a8b4ad05d598a7f8aa690add69f49cabb12ef2ef17b6c1553792aaee785b7c1703b05dd9d4889271cd5eba5629fad3d09b
+DIST cliff-3.9.0.tar.gz 82687 BLAKE2B d49840831e55a205e809abeb54a6c9d45e807a622dc9b02a104311b8a5ddda43415b504f7fd62075cc4cdf89a1b61605ecf32590fbca3d720c07da83d58890a2 SHA512 04b33e14c3b29a02dc04855044184f934919ff92dbc09003f620083e5815597f8dee7201fa33019dd58a3e701d4c3f9966be1f4d23e019a881fee9a9bc1f0dbd
diff --git a/dev-python/cliff/cliff-3.9.0.ebuild b/dev-python/cliff/cliff-3.9.0.ebuild
new file mode 100644
index 000000000000..37eabf731d66
--- /dev/null
+++ b/dev-python/cliff/cliff-3.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+# TODO: revert to rdepend once this is merged
+# https://github.com/openstack/cliff/pull/3
+DISTUTILS_USE_SETUPTOOLS=manual
+
+inherit distutils-r1
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="https://github.com/openstack/cliff"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest