summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2020-05-12 19:45:30 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-06-12 09:59:46 +0300
commit7bc10c9148bd6c64230349f40ac826bd4736cd8b (patch)
treeb8ad0d28549ed1dc2a381a7fc1a1bae90f4a856d /dev-python/click-plugins
parentmedia-gfx/openscad: drop old (diff)
downloadgentoo-7bc10c9148bd6c64230349f40ac826bd4736cd8b.tar.gz
gentoo-7bc10c9148bd6c64230349f40ac826bd4736cd8b.tar.bz2
gentoo-7bc10c9148bd6c64230349f40ac826bd4736cd8b.zip
dev-python/click-plugins: bump to 1.1.1
Closes: https://bugs.gentoo.org/722756 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15769 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/click-plugins')
-rw-r--r--dev-python/click-plugins/Manifest1
-rw-r--r--dev-python/click-plugins/click-plugins-1.1.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/click-plugins/Manifest b/dev-python/click-plugins/Manifest
index 322451961b55..fbc5d7f37cb5 100644
--- a/dev-python/click-plugins/Manifest
+++ b/dev-python/click-plugins/Manifest
@@ -1 +1,2 @@
DIST click-plugins-1.0.3.tar.gz 7950 BLAKE2B 4ed7d15c37b2eb127faac6179c06467507405d4fd3eb55d93e2210df0eae124167e0206fe9996298abbd7ee26edc8849d5c4062875db12ea92937f225408b4e6 SHA512 1eac03d57931bdf8e2f387164490436b3b921738936ee6cd9a58246e05e84133e77c47dd606a00d1b3e238a806bf83ffe7dc7c758a92d789cc229a94ed26e17f
+DIST click-plugins-1.1.1.tar.gz 8164 BLAKE2B 48d75b9445b72dca41516fe81d02c6fad8089630c0d49963f559a847b90c7897c8db64773c4ec5f4c162d0f2f4fdd14fe212d485765d38977145fd32acdd0dcb SHA512 bbd838f50603ac4e76daf3535fd5d27a17e17549addbc8b582df6d6193b4f07d743101ce52f0b71f326995fdfeac159805025770350ca2e7697f212dce0c4b1a
diff --git a/dev-python/click-plugins/click-plugins-1.1.1.ebuild b/dev-python/click-plugins/click-plugins-1.1.1.ebuild
new file mode 100644
index 000000000000..67d02a253fba
--- /dev/null
+++ b/dev-python/click-plugins/click-plugins-1.1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for click to enable registering CLI commands via setuptools entry-points"
+HOMEPAGE="https://github.com/click-contrib/click-plugins"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/click[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )"
+
+distutils_enable_tests pytest