summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-24 05:28:42 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-24 06:14:37 +0200
commitc41a377170849b822a6bfd5e35c1285c40a11f65 (patch)
tree6a6c2b9a785e36b27a057bc870333a007b2791be /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.47 (diff)
downloadgentoo-c41a377170849b822a6bfd5e35c1285c40a11f65.tar.gz
gentoo-c41a377170849b822a6bfd5e35c1285c40a11f65.tar.bz2
gentoo-c41a377170849b822a6bfd5e35c1285c40a11f65.zip
dev-python/boto3: Bump to 1.35.47
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.47.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 401feb3d0285..02d0aca64828 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.35.39.gh.tar.gz 872172 BLAKE2B 1baad362b9bfcf68ea89c9ba9ea473fcf245
DIST boto3-1.35.44.gh.tar.gz 875230 BLAKE2B 68c4fa6739a5d9cb720670a1bc14079ffac4b23101bd27367ec81675a34d717341c87257864a658c60d8a0c5fdea298f73db979b6aa64f65e9ea54479005d33b SHA512 6ff24f42088ae9f77b5e1ff033fab34c6a0c0f7fc46cf9cbe172b3151cf259e48c3804981afbc8de893dc2541105a04bc00d6becd3220c18243bda7ed206740b
DIST boto3-1.35.45.gh.tar.gz 875934 BLAKE2B 0b532577dd9c27c50d6ddeb9916205f53926a401c6acb10a83b3f1b812ec9b084dc940f85d74c16cd7575345b512c58c5bd3865eabcbff7a8e12010f5165dded SHA512 96468e6fd5bf266061f499aa79be0420ecf03f7dc3b9172e39e79cf1e144ddd3365a43c1e5a4c441e8fb7005968cd1571542a390ba4b864257f171d62b5abbca
DIST boto3-1.35.46.gh.tar.gz 876859 BLAKE2B c37a8af936c8b02e08fe08fc300bb46df748654819db3ff82cb93db1350b1c37983ab4de5c191dda43632bc1460fa4e5e711ff2517873620f8b600e0abd9a931 SHA512 911f2bcbbe5c130d540e8b9cf718b17d53a128db8d12f28c965832f574b7261e057d9b669561ed928c6bd500ad7059760e4d54a56af8c5bc0e7954e897f454bb
+DIST boto3-1.35.47.gh.tar.gz 877327 BLAKE2B 938f375ff94907713c91c849d2f16934088978dffbe93c0985d5a427ebe7aeea3e598dd373cf64c1a1d53cb7b3fd073c480b45aaf79e59697dee2a2c83102f5c SHA512 7df4fc0bb66df8ba1d1859ff727771a25e8eadcb6540f8b9ffc2b9f4d2358dca3b382e0868812d1bc6383abd19e4a73ea3328eb22f1d22583e23451f9b2a7279
diff --git a/dev-python/boto3/boto3-1.35.47.ebuild b/dev-python/boto3/boto3-1.35.47.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.47.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}