summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-08 06:22:13 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-08 06:41:04 +0200
commit6e290e74390693ebd75232391add77faa3b66045 (patch)
tree465b699920f358f09dbdc3690958683473a6460b /dev-python/blurb
parentdev-python/moto: Bump to 5.0.11 (diff)
downloadgentoo-6e290e74390693ebd75232391add77faa3b66045.tar.gz
gentoo-6e290e74390693ebd75232391add77faa3b66045.tar.bz2
gentoo-6e290e74390693ebd75232391add77faa3b66045.zip
dev-python/blurb: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blurb')
-rw-r--r--dev-python/blurb/Manifest1
-rw-r--r--dev-python/blurb/blurb-1.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/blurb/Manifest b/dev-python/blurb/Manifest
index cebdcf47b64e..67974539aeb3 100644
--- a/dev-python/blurb/Manifest
+++ b/dev-python/blurb/Manifest
@@ -1 +1,2 @@
DIST blurb-1.1.0.tar.gz 25064 BLAKE2B 4fbdd0d068cc7abb1ffa78dff70bd83feccc1bcfbf8ebb085c9f7e77e0f330d3759f10a94a5ca024b465c01f9d659496ae55162a52b7158a06caf2d114d36806 SHA512 9397173e7bf5babf02c96df27983462e7dd2a729e9eb0cacdf23ca3778336902d5c611ab5e2432bbc877344426d7c62ea8ae77719aa08da98f9b44365583b7ee
+DIST blurb-1.2.0.tar.gz 23573 BLAKE2B a7a15fed82fca3f13eb840379b186210d6b8a039f61d48c65dce33ab80e970791add63efe9986adb54e7bedd452a3a867791237e250c1949b5b90f06bfac28ae SHA512 ebfe4c84d1f813822d7a583b337460a840235b61257428a47b7b61eb43b4b38fffc84f0fe758c6f61e9ae4b8c9c1affd9038077ddf846f17032e4497f87b78ad
diff --git a/dev-python/blurb/blurb-1.2.0.ebuild b/dev-python/blurb/blurb-1.2.0.ebuild
new file mode 100644
index 000000000000..ed8b87d5b515
--- /dev/null
+++ b/dev-python/blurb/blurb-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2018-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to create and manage NEWS blurbs for CPython"
+HOMEPAGE="
+ https://github.com/python/core-workflow/tree/master/blurb
+ https://pypi.org/project/blurb/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest