summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 21:14:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 21:25:24 +0200
commitec75fc66974fc1d0b9751e23feb931e9f6f3c0e2 (patch)
tree9abd7b555dd1400f27573cc914d778fc72073136 /dev-python/blosc
parentmail-client/claws-mail: drop 3.x versions with USE=appindicator (diff)
downloadgentoo-ec75fc66974fc1d0b9751e23feb931e9f6f3c0e2.tar.gz
gentoo-ec75fc66974fc1d0b9751e23feb931e9f6f3c0e2.tar.bz2
gentoo-ec75fc66974fc1d0b9751e23feb931e9f6f3c0e2.zip
dev-python/blosc: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/blosc')
-rw-r--r--dev-python/blosc/Manifest1
-rw-r--r--dev-python/blosc/blosc-1.11.1.ebuild68
-rw-r--r--dev-python/blosc/files/blosc-1.11.1-numpy-2.patch51
3 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/blosc/Manifest b/dev-python/blosc/Manifest
index ac1040693d95..16659d2bec3f 100644
--- a/dev-python/blosc/Manifest
+++ b/dev-python/blosc/Manifest
@@ -1,2 +1 @@
-DIST python-blosc-1.11.1.gh.tar.gz 111262 BLAKE2B cb348253a24258d2649ebc0604acbf936b8ccc2b28c42c69da2fee72ddf87eb17a24657bc5d3c0530193a60f482555ce4cc5d168a18d9c2d79a13410d40670bc SHA512 21f8a697a3a902860a6ed72233984cf00c464ec0ddde9842a0c24b1e8e5ec4dd57b872096445a873d162d7529cba5c3666ba2a3ee3f9b1b18107d9636011281c
DIST python-blosc-1.11.2.gh.tar.gz 99160 BLAKE2B 79176961221a2dcdf389165b3ed0e629201605f806aca3e1ada1dd9b35c1acf13ea7fa6692a762f5e31270df327751642256a1c5bafb14fbed48ef69c6b9745c SHA512 56a53828669ac9d1452b247b8aad6bdfcb71ecffe9b8c7723e4405825704506946f150f54633b7e0886160255e5619c698b97847963c909e14c97808c04f39ab
diff --git a/dev-python/blosc/blosc-1.11.1.ebuild b/dev-python/blosc/blosc-1.11.1.ebuild
deleted file mode 100644
index 560554b6dde2..000000000000
--- a/dev-python/blosc/blosc-1.11.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1
-
-MY_P=python-blosc-${PV}
-DESCRIPTION="High performance compressor optimized for binary data"
-HOMEPAGE="
- https://www.blosc.org/
- https://github.com/Blosc/python-blosc/
- https://pypi.org/project/blosc/
-"
-SRC_URI="
- https://github.com/Blosc/python-blosc/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/c-blosc-1.19.0:=
-"
-DEPEND="
- ${RDEPEND}
-"
-# py-cpuinfo dep is irrelevant for us, as it is only used to configure
-# bundled c-blosc build
-BDEPEND="
- dev-python/scikit-build[${PYTHON_USEDEP}]
- test? (
- dev-python/numpy[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( ANNOUNCE.rst README.rst RELEASE_NOTES.rst )
-
-PATCHES=(
- # https://github.com/Blosc/python-blosc/pull/329
- "${FILESDIR}/${P}-numpy-2.patch"
-)
-
-src_configure() {
- export USE_SYSTEM_BLOSC=1
- export BLOSC_DIR="${EPREFIX}/usr"
-}
-
-python_compile() {
- distutils-r1_python_compile
-
- # scikit-build is broken and reuses the same build
- # https://github.com/scikit-build/scikit-build/issues/633
- rm -r _skbuild || die
-}
-
-python_test() {
- "${EPYTHON}" -m blosc.test -v || die
-}
diff --git a/dev-python/blosc/files/blosc-1.11.1-numpy-2.patch b/dev-python/blosc/files/blosc-1.11.1-numpy-2.patch
deleted file mode 100644
index 97010c0a4bf6..000000000000
--- a/dev-python/blosc/files/blosc-1.11.1-numpy-2.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 4823cb746023821166756322becd3fc242cd0b32 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sun, 16 Jun 2024 08:59:36 +0200
-Subject: [PATCH] Fix test failures with NumPy 2
-
-* Replace deprecated `np.alltrue()` with `np.all()` (available since
- NumPy 1.7.0).
-
-* Cast NumPy boolean to `bool()`, to ensure doctests pass both with
- NumPy 2 (using `np.True_`) and NumPy 1 (using plain `True`).
----
- blosc/toplevel.py | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/blosc/toplevel.py b/blosc/toplevel.py
-index ad9c12d..4d2d413 100644
---- a/blosc/toplevel.py
-+++ b/blosc/toplevel.py
-@@ -514,7 +514,7 @@ def compress_ptr(address, items, typesize=8, clevel=9, shuffle=blosc.SHUFFLE,
- items, np_array.dtype.itemsize)
- >>> d = blosc.decompress(c)
- >>> np_ans = numpy.fromstring(d, dtype=np_array.dtype)
-- >>> (np_array == np_ans).all()
-+ >>> bool((np_array == np_ans).all())
- True
-
- >>> import ctypes
-@@ -640,7 +640,7 @@ def decompress_ptr(bytes_like, address):
- items, np_array.dtype.itemsize)
- >>> np_ans = numpy.empty(items, dtype=np_array.dtype)
- >>> nbytes = blosc.decompress_ptr(c, np_ans.__array_interface__['data'][0])
-- >>> (np_array == np_ans).all()
-+ >>> bool((np_array == np_ans).all())
- True
- >>> nbytes == items * np_array.dtype.itemsize
- True
-@@ -769,12 +769,12 @@ def unpack_array(packed_array, **kwargs):
- >>> len(parray) < a.size*a.itemsize
- True
- >>> a2 = blosc.unpack_array(parray)
-- >>> numpy.alltrue(a == a2)
-+ >>> bool(numpy.all(a == a2))
- True
- >>> a = numpy.array(['å', 'ç', 'ø'])
- >>> parray = blosc.pack_array(a)
- >>> a2 = blosc.unpack_array(parray)
-- >>> numpy.alltrue(a == a2)
-+ >>> bool(numpy.all(a == a2))
- True
- """
-