summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-08 04:50:33 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-08 04:50:33 +0200
commitcf5a54b8548840fb5b53fbfb78c2eacd945ce545 (patch)
tree3781358d0b6637e1b8f3e41d6c4a2a61261ff0f5 /dev-python/black
parentdev-python/markupsafe: Bump to 3.0.0 (diff)
downloadgentoo-cf5a54b8548840fb5b53fbfb78c2eacd945ce545.tar.gz
gentoo-cf5a54b8548840fb5b53fbfb78c2eacd945ce545.tar.bz2
gentoo-cf5a54b8548840fb5b53fbfb78c2eacd945ce545.zip
dev-python/black: Bump to 24.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/black')
-rw-r--r--dev-python/black/Manifest1
-rw-r--r--dev-python/black/black-24.10.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/black/Manifest b/dev-python/black/Manifest
index 1ba94d5b0a17..dff2fec2c746 100644
--- a/dev-python/black/Manifest
+++ b/dev-python/black/Manifest
@@ -1,2 +1,3 @@
+DIST black-24.10.0.tar.gz 645813 BLAKE2B ba53b3d38d982c81d66291318ba6ab7df75779207fea77af3a4554cebaa23061d9d22f97613faa38b869694edcf56ae0001ff27eb34fba1e1bc8732dbf0a0796 SHA512 36285528b2a3ca9b68b806cf43cf04061f80e0ad5e693c70d2dc254b59d15f41ec5c2a4328d4cda42abe005def2d86d8fc501c1649b223a225c8bddddf82589a
DIST black-24.4.2.tar.gz 642299 BLAKE2B aa62394dc4a14fd6dd49502a86e46e7f707d6342127e2fb3b5cb7365ab392f5a0514df548d30219e9b6ed1f9d8ca80241ea206a06011ef8dc3d770191d3328ce SHA512 f3fb63fdbff947a217ad371939a6eaac1e818f58fb924516639f3c9469f0db6fbda8d4b207163d4a6db8a58a048fefe46fbfdb1ddf40f91348bd767208e60f35
DIST black-24.8.0.tar.gz 644810 BLAKE2B 8961bca9caf4db7178b3bdc4cccbf8bea667329cb2a13e388fa966b0cc9c059edf6ee17f281b72b9b8b66359781d525cc3983b2cb7a5e0638418d9454e51b188 SHA512 2ba2579964764032d30378232f5874a5d71981eb76706ed12004c08c78eaa56bfb8e0740e513280b9246f54082443c64aa31d31955fdccae9c6e6ba96f54e1cc
diff --git a/dev-python/black/black-24.10.0.ebuild b/dev-python/black/black-24.10.0.ebuild
new file mode 100644
index 000000000000..29e176c82187
--- /dev/null
+++ b/dev-python/black/black-24.10.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="The uncompromising Python code formatter"
+HOMEPAGE="
+ https://black.readthedocs.io/en/stable/
+ https://github.com/psf/black/
+ https://pypi.org/project/black/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mypy_extensions-0.4.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22.0[${PYTHON_USEDEP}]
+ >=dev-python/pathspec-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.0.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/aiohttp-3.10[${PYTHON_USEDEP}]
+ dev-python/aiohttp-cors[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "blackd - HTTP API for black" \
+ "dev-python/aiohttp dev-python/aiohttp-cors"
+}