summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 00:59:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 01:12:56 +0100
commite53553cfff16a46575bba1d04d3909a2ebbcf782 (patch)
tree73088914fea69e5df5cfead7b94837bbdc9d4a40 /dev-python/atpublic
parentdev-lang/python: Backport CVE-2021-23336 fix to 2.7 (diff)
downloadgentoo-e53553cfff16a46575bba1d04d3909a2ebbcf782.tar.gz
gentoo-e53553cfff16a46575bba1d04d3909a2ebbcf782.tar.bz2
gentoo-e53553cfff16a46575bba1d04d3909a2ebbcf782.zip
dev-python/atpublic: Bump to 2.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/atpublic')
-rw-r--r--dev-python/atpublic/Manifest1
-rw-r--r--dev-python/atpublic/atpublic-2.1.3.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/atpublic/Manifest b/dev-python/atpublic/Manifest
index 33894b1b4cb1..e64b94195aa8 100644
--- a/dev-python/atpublic/Manifest
+++ b/dev-python/atpublic/Manifest
@@ -1,2 +1,3 @@
DIST atpublic-1.0.tar.gz 13611 BLAKE2B b5ce4cbbe950943c001e25c3f0c1fe6c25a99a96e4c630844a409cb0ae9a2e7d8fae8d010864364bb2bc948ce78ed17bef5c1f1ca1435faca439f62521bcc719 SHA512 f9e6f7bbbe12d86df5bc849c432e789fb55c6d19b9d6b3fb2462ea38aa8ad6602504a30a95ec14e001f62709ae5e11ae29258b9cb7a71eaa48879f9cb0cb19d8
DIST atpublic-2.1.2.tar.gz 16298 BLAKE2B c388743e2348b9143926f4c3a5e7908382799b6728d1768fcc5779eae93d45b5741ec080b5255de39be14a2a3a9e2fecc657802f91df1df8e626910582785a9b SHA512 cfde028756f56c7ca83b91e7d8653cee4575fb581669ee02c56a08c92ae2a6c1e51db76b6def1959354d3e931418a4dd09b78236268170d8c79620477836fe08
+DIST atpublic-2.1.3.tar.gz 16373 BLAKE2B a93a53fbee7b46eb949090d6c8ffa911db613b926f9acdd56932576b492a5ac3949ba958ff6bb988e0f2783c4630a7bffd9610af41cc983a63983d198962b342 SHA512 deba5654471330454b6327e0911f71426e31f78128b8c5607e4dfca292f017da2c2326a6a59e76097ed30560e3404a47a0c0e034bc053c8348c20f40c002ec9f
diff --git a/dev-python/atpublic/atpublic-2.1.3.ebuild b/dev-python/atpublic/atpublic-2.1.3.ebuild
new file mode 100644
index 000000000000..81e2361f4d03
--- /dev/null
+++ b/dev-python/atpublic/atpublic-2.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A decorator to populate __all__ and the module globals"
+HOMEPAGE="https://gitlab.com/warsaw/public"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' python3_7)"
+BDEPEND="
+ test? ( dev-python/sybil[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov=public::' setup.cfg || die
+ distutils-r1_src_prepare
+}