summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-18 04:46:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-18 04:54:50 +0200
commit9667ad5720082ebb78de4be571e0c33453b0c048 (patch)
treede11c2f12b77d1fbe26baa0c191c55ea28bbcb95 /dev-python/aiosqlite
parentdev-python/cfn-lint: Bump to 0.77.1 (diff)
downloadgentoo-9667ad5720082ebb78de4be571e0c33453b0c048.tar.gz
gentoo-9667ad5720082ebb78de4be571e0c33453b0c048.tar.bz2
gentoo-9667ad5720082ebb78de4be571e0c33453b0c048.zip
dev-python/aiosqlite: Bump to 0.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiosqlite')
-rw-r--r--dev-python/aiosqlite/Manifest1
-rw-r--r--dev-python/aiosqlite/aiosqlite-0.19.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/aiosqlite/Manifest b/dev-python/aiosqlite/Manifest
index cce382dbcf07..fc3b0039ba6b 100644
--- a/dev-python/aiosqlite/Manifest
+++ b/dev-python/aiosqlite/Manifest
@@ -1 +1,2 @@
DIST aiosqlite-0.18.0.tar.gz 27066 BLAKE2B 2743db7770b8377a1ab2b11b286684840b1ace9015180fb18590026e4607f78f72068765ea5ab69f9b2fd6ad96007dbbb517d371c2142930f2a587f0b13f81ea SHA512 dcab1bac1b32a86f31957a2f297969ba25cf43cd129afba5810812124964640744cdcbf9764c0037adb9b6cd917cd816a26823578ffb16d864be19f92373d59f
+DIST aiosqlite-0.19.0.tar.gz 21832 BLAKE2B 0cd367979e84af23e7ca9965535ab6477bb78c6b2b0c6af3a8698bbde6400dee80d468b99f125ae03ab98053212170cbbaaeac5134e9f85dc66704eafa96f78f SHA512 56debffdb73b6ec98bb69ce2b711e53417cbcb06501a2dc94558157c2cd010f9f56345bcf5378a17eb064ac6bd5f3638650edffcd1f73883bdeae7476afa96e8
diff --git a/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild b/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild
new file mode 100644
index 000000000000..bef55760e148
--- /dev/null
+++ b/dev-python/aiosqlite/aiosqlite-0.19.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="asyncio bridge to the standard sqlite3 module"
+HOMEPAGE="
+ https://aiosqlite.omnilib.dev
+ https://pypi.org/project/aiosqlite/
+ https://github.com/omnilib/aiosqlite
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest
+
+# AttributeError: 'str' object has no attribute 'supported'
+#distutils_enable_sphinx docs dev-python/m2r