summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-01 05:50:28 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-01 05:50:28 +0200
commit78a42089aca2693653733be6cd300dd8f08b171d (patch)
tree79fac0ae3637798d5ba7acc53eea278e50a314b6 /dev-python/aiohappyeyeballs
parentdev-python/pyproject-metadata: Bump to 0.9.0_beta6 (diff)
downloadgentoo-78a42089aca2693653733be6cd300dd8f08b171d.tar.gz
gentoo-78a42089aca2693653733be6cd300dd8f08b171d.tar.bz2
gentoo-78a42089aca2693653733be6cd300dd8f08b171d.zip
dev-python/aiohappyeyeballs: Bump to 2.4.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest1
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index 8da54e32b9b3..19a33f53109d 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1,2 +1,3 @@
DIST aiohappyeyeballs-2.4.0.gh.tar.gz 55452 BLAKE2B 11e34818ed652b2904e78c7a48726d68118a6ecb811be8dcd5008acefd96093b8a2bf25bf92ebb79cdac4735100cec9ca05c856034900f8cda93f45be4f4d627 SHA512 8c2e931fa8b0423e1958a45ac5a040f35e9c0c4df7e4bd6662b5c0288fd25f64cce556cb386b27d07c7438b901a3468fa993c929a3b9c221fb5a318e7809db5a
DIST aiohappyeyeballs-2.4.2.gh.tar.gz 57136 BLAKE2B 557eb7de33467f05c1b558367b16a9af9a3435bf290b4df3d5f189aeee2f336fa7b4d6fb1e523f04fcac0ccb382100b4976e6577e9e7227fa7b417589fabf8f8 SHA512 c2c4e585a00ddcbc7007779a8d59ceb0d5ce9dcce4f929efce2453b6cf370834ea29ee60769fd2885111130eaa89c3d2084702cd247141052d37833e370bbf6e
+DIST aiohappyeyeballs-2.4.3.gh.tar.gz 60766 BLAKE2B 5338d9bc4ee714a516c027db2753c885ae76c3418dbfac3a7ac7447e3a868649237c9221d719b3ddb6d9e67f1193533a1c8b2a80fcd3a45bf6046ed434e09859 SHA512 e8ec696c6e5988f86011a6fe65461e97c68ff466568c5071dd6cd62d0b5cb2f17b61bba934b6402bdfc964a8003e5f172b73240fbcfce71fc85afb42915a6080
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild
new file mode 100644
index 000000000000..0aa0cdf41541
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.4.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}