summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 09:52:53 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 10:18:37 +0200
commitc5e628f129978d26b99bf5b30983ad462d93a7b4 (patch)
tree245fb95dbc296a1361238c9a00db40a163e12523 /dev-python/aesara
parentdev-ml/ppx_fixed_literal: 0.15.0 bump (diff)
downloadgentoo-c5e628f129978d26b99bf5b30983ad462d93a7b4.tar.gz
gentoo-c5e628f129978d26b99bf5b30983ad462d93a7b4.tar.bz2
gentoo-c5e628f129978d26b99bf5b30983ad462d93a7b4.zip
dev-python/aesara: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest2
-rw-r--r--dev-python/aesara/aesara-2.6.0.ebuild80
-rw-r--r--dev-python/aesara/aesara-2.6.2.ebuild80
3 files changed, 0 insertions, 162 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index c35e82cfb67c..ec0f87806588 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,4 +1,2 @@
DIST aesara-rel-2.5.3.tar.gz 8191431 BLAKE2B 698bc3b6f7e84288be3318796989d13d7de92f72c66abfa83b14c08f6310f974f7381d729e712c2bd5e76f398d74a3c5dc03d7515a22254261312e586e3fd461 SHA512 5c1ad9d6ad1fb58be1477713d863f2b1371544ea8293d8e9e1a690860a0483b83c9558827856a2546498bab26360f141a5ee97d4c7f3f2aad773e84f9766a59b
-DIST aesara-rel-2.6.0.tar.gz 7846131 BLAKE2B 23e1f115eb2e8794a00d29fa2b9705ba6bf0d17c9bb290675f9406e4008b24b45dfd9b2732cb6fc3c6ce18154a3d75b6b0fc750a99f76588cab91387dbc4728d SHA512 8acff0f3fbb8969970b988f363cb3e2107fd3ee5450f238e426f0959d6bf42909c6eb2951b1803629148a57a9a27c47b4364756942a42692b44abf151cf736d2
-DIST aesara-rel-2.6.2.tar.gz 7846413 BLAKE2B bd25da68fc0bc138eedda1c7203ef1cf0e3f0cde84e9eb2be0aed9baeedf292f7270e0117cbcb72aeb2542727b24d4a5374e2c2f930945240b911916942b10fe SHA512 e1da313d5f2a8498565bb0cc1442b1c3eae0206caf09976903c54314b4002a68dae53d7289ad1fb06e5e8ed015613d989c4c5db85d57f6c072d2e2414019acd5
DIST aesara-rel-2.6.3.tar.gz 7845423 BLAKE2B 66b84a10337efc01e37d82793da56b61b1825829d982e24e0f93ebb67cd3c22e5bb2e37c71ab8bd9648b039efaf4c667dc53df2a9613ba9370c2138eb74ca400 SHA512 e0a804c0c3c1cd24753a237c386df9600d2b01cf4991aeca3d794df4068f584a9ab5341b72fa5695ccb9d06f1e4954f450436e3a7ebe4c2efc1354a5c2e5979d
diff --git a/dev-python/aesara/aesara-2.6.0.ebuild b/dev-python/aesara/aesara-2.6.0.ebuild
deleted file mode 100644
index 5bcb330fb0af..000000000000
--- a/dev-python/aesara/aesara-2.6.0.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.tar.gz
-"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
- )
- local EPYTEST_IGNORE=(
- # we do not package numba
- tests/link/test_numba.py
- tests/link/test_numba_performance.py
- )
-
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-python_compile() {
- esetup.py build_py
- distutils-r1_python_compile
- rm "${BUILD_DIR}/install$(python_get_sitedir)/bin/__init__.py" || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}
diff --git a/dev-python/aesara/aesara-2.6.2.ebuild b/dev-python/aesara/aesara-2.6.2.ebuild
deleted file mode 100644
index 5bcb330fb0af..000000000000
--- a/dev-python/aesara/aesara-2.6.2.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.tar.gz
-"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- >=dev-python/numpy-1.17.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
- )
- local EPYTEST_IGNORE=(
- # we do not package numba
- tests/link/test_numba.py
- tests/link/test_numba_performance.py
- )
-
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}
-
-python_compile() {
- esetup.py build_py
- distutils-r1_python_compile
- rm "${BUILD_DIR}/install$(python_get_sitedir)/bin/__init__.py" || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}