summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-20 17:59:10 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-21 18:13:19 -0700
commitb1cc437e84c3e375000bf6cf81202cd7f963ff4b (patch)
tree83b60bf748ad802cae6a899e22dcdedf3166973d /dev-python/SaltTesting
parentdev-python/pyicu: bump to 2.4.3 (diff)
downloadgentoo-b1cc437e84c3e375000bf6cf81202cd7f963ff4b.tar.gz
gentoo-b1cc437e84c3e375000bf6cf81202cd7f963ff4b.tar.bz2
gentoo-b1cc437e84c3e375000bf6cf81202cd7f963ff4b.zip
dev-python/SaltTesting-2018.9.21: Version bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/SaltTesting')
-rw-r--r--dev-python/SaltTesting/Manifest1
-rw-r--r--dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild33
-rw-r--r--dev-python/SaltTesting/files/SaltTesting-2018.9.21-python37.patch21
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/Manifest b/dev-python/SaltTesting/Manifest
index 33a9a726582c..925460c927ad 100644
--- a/dev-python/SaltTesting/Manifest
+++ b/dev-python/SaltTesting/Manifest
@@ -1 +1,2 @@
DIST SaltTesting-2018.1.16.tar.gz 88951 BLAKE2B 41061e691f97e95ac672b463cb7dc02af4ea70553577ac80d63800198aba8de8565c021381718a32fe76fd958446c3057dec25312a1f961b7696e19570dcee93 SHA512 1ea200ebd7688de35049a45816d87fb3b24f0a862384419a3796f191efb268cdad8a69187261db91de1151f7df8147251910170fd56a50335612bf2f29f09c0a
+DIST SaltTesting-2018.9.21.tar.gz 459708 BLAKE2B c0c6d853ab335432464140b6db8939ae87b58f50c0ea63a547a09ab3e1899b52053e3f9ea90b183268b807db5d7f323f09f9b6d4186e1b4214d6984486f37139 SHA512 9ce79aaa0fd90fd75fa2a64112563751837d441518426cbdb5df93721fd186e9fe33609341a75bc173781cd9a97b477809a4c2e2d4fdd29a5331f0d096983db8
diff --git a/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild b/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
new file mode 100644
index 000000000000..db921ba1591e
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="https://saltstack.com/community/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/saltstack/salt-testing/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/salt-testing-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+PATCHES=(
+ "${FILESDIR}/SaltTesting-2018.9.21-python37.patch"
+)
diff --git a/dev-python/SaltTesting/files/SaltTesting-2018.9.21-python37.patch b/dev-python/SaltTesting/files/SaltTesting-2018.9.21-python37.patch
new file mode 100644
index 000000000000..b12d4231bbd8
--- /dev/null
+++ b/dev-python/SaltTesting/files/SaltTesting-2018.9.21-python37.patch
@@ -0,0 +1,21 @@
+diff --git a/salttesting/case.py b/salttesting/case.py
+index 4918915..19e47cc 100644
+--- a/salttesting/case.py
++++ b/salttesting/case.py
+@@ -140,14 +140,14 @@ class ShellTestCase(TestCase, AdaptedConfigurationTestCaseMixIn):
+ )
+ return self.run_script('salt-ssh', arg_str, with_retcode=with_retcode, catch_stderr=catch_stderr, raw=True)
+
+- def run_run(self, arg_str, with_retcode=False, catch_stderr=False, async=False, timeout=60, config_dir=None):
++ def run_run(self, arg_str, with_retcode=False, catch_stderr=False, async_flag=False, timeout=60, config_dir=None):
+ '''
+ Execute salt-run
+ '''
+ arg_str = '-c {0}{async_flag} -t {timeout} {1}'.format(config_dir or self.get_config_dir(),
+ arg_str,
+ timeout=timeout,
+- async_flag=' --async' if async else '')
++ async_flag=' --async' if async_flag else '')
+ return self.run_script('salt-run', arg_str, with_retcode=with_retcode, catch_stderr=catch_stderr)
+
+ def run_run_plus(self, fun, *arg, **kwargs):