summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-17 03:36:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-17 04:08:31 +0100
commit27059c97e8e3615ac3fea65564c7078ecdbc411f (patch)
tree94e2c8f675f3487baa43e768f324d1466fb3c53b /dev-python/Nuitka
parentdev-python/hypothesis: Bump to 6.119.2 (diff)
downloadgentoo-27059c97e8e3615ac3fea65564c7078ecdbc411f.tar.gz
gentoo-27059c97e8e3615ac3fea65564c7078ecdbc411f.tar.bz2
gentoo-27059c97e8e3615ac3fea65564c7078ecdbc411f.zip
dev-python/Nuitka: Bump to 2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest1
-rw-r--r--dev-python/Nuitka/Nuitka-2.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
index 99b796c40fb5..92cc9169ca6a 100644
--- a/dev-python/Nuitka/Manifest
+++ b/dev-python/Nuitka/Manifest
@@ -1 +1,2 @@
DIST Nuitka-2.4.11.tar.gz 3730066 BLAKE2B f75729f1aeb2c16ee87ae428af96e5dda27ca4bf926fa7625e6c521d2a740cac827a952d45daa569400c73a1121f571dc3450b43516b8357fe965ea5e4cf5378 SHA512 db516d6ce5b557401e9549b2cf816f15af147773eae255c89b382a60423ddfdf8ac20d4efcb7c2682d17b9cea26351a4decd9f7af6f5cdc451de237ea2df8a49
+DIST Nuitka-2.5.tar.gz 3775959 BLAKE2B 25c91811fd7f1750c4be68031503c72694b512818aff9da57ea941257b376aee1db5921f7e9acec4b836a030a5ddcf329ada8d2e4305c735d6abefb3f97306e4 SHA512 265bd1d076acb2470598a78d6d66d9d246b27345b93bd28da0ff75621d2cf6f221760517e74c25d660b3c90eba2738eef1fb10978af97f9dc6c7720495ccdeed
diff --git a/dev-python/Nuitka/Nuitka-2.5.ebuild b/dev-python/Nuitka/Nuitka-2.5.ebuild
new file mode 100644
index 000000000000..1a65e72f7c93
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-2.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}