summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 16:44:19 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 17:10:31 +0200
commite86edf4cf6a97b8944a36e22e930764a3312212b (patch)
tree58b8bb16d88cfabc5546cd4327a3d385d9e708b2 /dev-python/CppHeaderParser
parentdev-python/three-merge: enable py3.10 (diff)
downloadgentoo-e86edf4cf6a97b8944a36e22e930764a3312212b.tar.gz
gentoo-e86edf4cf6a97b8944a36e22e930764a3312212b.tar.bz2
gentoo-e86edf4cf6a97b8944a36e22e930764a3312212b.zip
dev-python/CppHeaderParser: enable py3.9,py3.10
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/CppHeaderParser')
-rw-r--r--dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
index 5c10dae1bfdc..ec77d48706e2 100644
--- a/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
+++ b/dev-python/CppHeaderParser/CppHeaderParser-2.7.4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -14,6 +14,6 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="dev-python/ply"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"