summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-02-09 18:56:15 +0100
committerThomas Deutschmann <whissi@gentoo.org>2021-02-09 19:43:50 +0100
commitb49acf108677620e61279a8abffe382b30b2e605 (patch)
tree8b3111bf98413be274f8ea5d6932ce817c2bac89 /dev-php
parentnet-dns/dnsviz: bump to v0.9.2 (diff)
downloadgentoo-b49acf108677620e61279a8abffe382b30b2e605.tar.gz
gentoo-b49acf108677620e61279a8abffe382b30b2e605.tar.bz2
gentoo-b49acf108677620e61279a8abffe382b30b2e605.zip
dev-php/phing: bump to v2.16.4
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phing/Manifest1
-rw-r--r--dev-php/phing/phing-2.16.4.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-php/phing/Manifest b/dev-php/phing/Manifest
index ece47f9b3227..94f9936900f7 100644
--- a/dev-php/phing/Manifest
+++ b/dev-php/phing/Manifest
@@ -1,2 +1,3 @@
DIST phing-2.16.1.tgz 4149013 BLAKE2B 266c124237d437361e9e18a42c9358fc18cfacfaa798a3a92a31858b7c1af847cde2cac43e0fcfe3759e8291639de9ec564f977fe00939316dbacdfd266e4e92 SHA512 e0832396dac9fbd43680f01acfa55f3ed2819726ace1db4ec9addf18c9c023c4f63143c6a63bbe1b16c2bd19dba54f503efdc77d772a3239bc8f9efe0ab375bb
DIST phing-2.16.3.tgz 858508 BLAKE2B f1125420989af4ec9d1795044d96131a78012d5000eb8adaf9d076f4e2bbceeab0f11b9a24b79425fff179b4ec9dbe5a33aba65dbd4de6b70e64c1cb7c243004 SHA512 b564ddea969bd2a538e09768f6e4d88e9e61ecf6d783db4e328ef9be00099b1fee6ac6dac49b61bab6243e61969131d22869e95b8f063b9c233fd23afa314d30
+DIST phing-2.16.4.tgz 860196 BLAKE2B 0db5171e4076ab07de6118fb11daedef27247b785a2f15899d7b24c677edee334df2b2dbb1d7386e546cfa9d81cea942d967531793333d67d70e8898e2472978 SHA512 e3c0aa808e75c1f4ed73bd179261dfa5e6c52ae480567d4503cade939ef4b7430a1ac90097bfb246e0dd29e3bca6a22b200a995e4dd5442b283948aaf26ee311
diff --git a/dev-php/phing/phing-2.16.4.ebuild b/dev-php/phing/phing-2.16.4.ebuild
new file mode 100644
index 000000000000..7d5bc50b8c70
--- /dev/null
+++ b/dev-php/phing/phing-2.16.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP project build system based on Apache Ant"
+HOMEPAGE="https://www.phing.info/"
+SRC_URI="https://www.phing.info/get/${P}.tgz"
+
+LICENSE="FDL-1.3 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples minimal zip"
+
+RDEPEND="dev-lang/php:*[cli,xml,xslt,zip?]
+ dev-php/symfony-yaml
+ !minimal? (
+ dev-php/PEAR-HTTP_Request2
+ dev-php/PEAR-PEAR_PackageFileManager
+ dev-php/PEAR-VersionControl_SVN
+ dev-php/PHP_CodeCoverage
+ dev-php/phpDocumentor
+ dev-php/phpmd
+ dev-php/phpunit
+ dev-php/simpletest
+ dev-php/xdebug
+ )"
+
+S="${WORKDIR}"
+
+src_install() {
+ dodoc CHANGELOG.md CREDITS.md README.md
+ dodoc -r docs/docbook5/en/output/hlhtml
+ use doc && dodoc -r docs/api
+ use examples && dodoc -r docs/example
+
+ # Install the executable (and the PHP file it wraps) outside of the
+ # PHP include directory, since nobody should be including it.
+ exeinto "/usr/share/${PN}/bin"
+ doexe "bin/${PN}"
+ insinto "/usr/share/${PN}/bin"
+ doins "bin/${PN}.php"
+ dosym "../share/${PN}/bin/${PN}" "/usr/bin/${PN}"
+
+ # Phing tries to get the version number from this file.
+ insinto "/usr/share/${PN}/etc"
+ doins etc/VERSION.TXT
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ # But install the library under /usr/share/php.
+ insinto "/usr/share/php"
+ doins -r "classes/${PN}"
+}